Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28434 Discussions

Visual Studio does not answer to type for 30 seconds

jmloriot
Beginner
886 Views

I use Microsoft VS 2022 and the latest version of Intel fortran

When typing code, every other minute Visual studio is very busy writing on the disk and does not answer to my typing for at least 30 seconde

It si very upseting

please tell me what to do

0 Kudos
5 Replies
jimdempseyatthecove
Honored Contributor III
858 Views

With issues like this - Google is your friend. Enter a search for:

    Visual Studio slow typing

 

The first 3 responses (and referenced links in those articles) point to an issue with intelisense verses Anti-Virus.

From stackoverflow.com:

>>

Answer

 
 

I learned What was the cause of the problem, and it's intelisense.

How to speed up intelisense...

it's that MS Defender that comes with Windows 8 and 10 is slowing down intelisense.

Adding following processes and folders to exclusion list in secrutiy center speeds up intelisense:

1. Microsoft.ServiceHub.Controller.exe
2. ServiceHub.Host.CLR.x86.exe
3. ServiceHub.IdentityHost.exe
4. ServiceHub.SettingsHost.exe
5. ServiceHub.VSDetouredHost.exe
6. vcpkgsrv.exe
7. VcxprojReader.exe
8. Entry folder containing your project files

If you use different AV, then just put these processes to exclusion list in your AV settings.

Following are steps that can help speed up VS and intelisense:

Tools > options > environment > automatically adjust visual experience set to off and toggle on "enable rich client visual experience"
tools > options > text editor > C/C++ > advanced > Code analysis > disable code analysis.
Tools > options > text editor > all languages > codelens > disable codelens
Tools > options > environment > international settings > same as MS Windows
Tools > options > source control > set to none
Tools > manage extensions > disable extensions
set up precompiled headers for each project

edit: If the above doesn't work for a long time (as was in my case) then turn off Windows defender real time protection service. That indeed makes VS and intelisense respond instantly.

<<

Jim Dempsey

 

 

0 Kudos
JohnNichols
Valued Contributor III
846 Views

Screenshot_20221111_094804.png

Jim:  In Windows 11 it is not turned on by default. 

0 Kudos
sulinelanie
Beginner
799 Views

Hey,

 

Turn off overtype mode: Click File > Options. Click Advanced. Under Editing options, clear both the Use the Insert key to control overtype mode and the Use overtype mode check boxes.

0 Kudos
jmloriot
Beginner
638 Views

Thank you all

I have done everything that was suggested but what really made it was to turn off "check includes"

I now enjoy working with Fortran Visual Studio

 

0 Kudos
JohnNichols
Valued Contributor III
622 Views

Yes, it is a pretty good language and the IDE is a lot better than the integration of VEDIT+ and MS Fortran 3.03 in 1988, although I still remember it with some fondness, 20 MB hard drive and 5.25 inch floppy drives.  

I remember when the small Japanese floppy disks came out and I thought they were cool.  

 

0 Kudos
Reply