Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

cannot build an x64 fortran program

Hi, my os is win10 and I have intel parallel studio xe 2016 cluster edition and vs2015 professional edition installed. Now I want to build an x64 fortran code, in build--configuration manager, I have set the active solution platform to be x64. However after building, I got "fatal error LNK1104: cannot open file 'ifconsol.lib'", while building a win32 code shows no such error. What might be the problem? Thanks.  Attached please find my configuration. 

"

0 Kudos
11 Replies
Highlighted
Employee

Perhaps you didn't install

Perhaps you didn't install the 64-bit compiler/library components?

Do you have an ifconsol.lib under a path: C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2016\windows\compiler\lib\intel64_win ?

If not then via Control Panel, use Uninstall/Change for Intel Parallel Studio XE 2016, select Modify, and then step through the menus making certain when you see the Architecture pane that both IA-32 and Intel(R) 64 are checked. Click next and check under the Intel Visual Fortran component (click the "+" plus symbol to expand) that both IA-32 and Intel(R) 64 are checked to be installed and proceed with the installation.

0 Kudos
Highlighted
Beginner

I do have the intel64

I do have the intel64 architecture installed and the above mentioned folder and file both exist.

0 Kudos
Highlighted
Employee

Ok. Please attach a build.log

Ok. Please attach a build.log and your Fortran project's .vfproj file.

0 Kudos
Highlighted
Beginner

Attached please find the

Attached please find the buildlog and .vfproj file, thanks.

0 Kudos
Highlighted
Employee

Ok, thank you. Can you please

Ok, thank you. Can you please next set, Properties > Linker > General  > Show Progress to Display Some Progress Messages (/VERBOSE:LIB)

And then rebuild the x64 configuration and provide the build log for this. I would actually like to see this verbose output for both the x64 and win32 configuration builds.

Is your Intel Parallel Studio XE 2016 also installed on the D: drive?

0 Kudos
Highlighted
Beginner

Attached please find the new

Attached please find the new buildlog after setting /VERBOSE:LIB and indeed the intel parallel studio xe 2016 is installed on the d: drive. If I set the active solution platform to be x86, then the buildlog is also attached, which is named as buildlongw32.

0 Kudos
Highlighted
Employee

Thank you. VS is not giving

Thank you. VS is not giving me what I want.

Can you compare the values set in the Libraries field setting for the x64 tab under Tools >  Options > Intel Compilers and Tools > Visual Fortran > Compilers  to those shown below.  You will notice there is a tab for Win32 and x64.

The values for Libraries under x64 should be like:

$(IFortInstallDir)compiler\lib\Intel64_win
$(IFortInstallDir)mkl\lib\Intel64_win
$(VCInstallDir)atlmfc\lib\amd64
$(VCInstallDir)lib\amd64
$(WindowsSdkDir)lib\winv6.3\um\x64
$(UniversalCRTSdkDir)lib\winv10.0\ucrt\x64
$(UniversalCRTSdkDir)Lib\$(UCRTVersion)\ucrt\x64

If you are not seeing values like this then press Reset on this pane, check the values again, and if they compare then try x64 build again.

0 Kudos
Highlighted
Beginner

Thanks, Kevin, problem solved

Thanks, Kevin, problem solved. The libraries for x64 are not those as you mentioned and after I reset their values, now I can build x64 project, thank you again for your help.
0 Kudos
Highlighted
Employee

Great! I appreciate your

Great! I appreciate your patience with the numerous requests and am glad we resolved this.

I'm also just curious, did you have any earlier version of Parallel Studio XE installed on the system before this current version?

0 Kudos
Highlighted
Beginner

No. In fact, recently I

No. In fact, recently I downloaded and installed ms-mpi. In order to include the mpi library, I erroneously changed the library path for x64 and I did not even remember it, that's why I cannot build x64 code.
0 Kudos
Highlighted
Employee

Ok, thank you, that’s

Ok, thank you, that’s settling.

0 Kudos