Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
72 Views

configuration after install on RHEL 7 (Scientific Linux 7)

I recently installed ifort (version 2019, update 2) on an i7 computer running Scientific Linux 7 (this is Red Hat 7, recompiled and released for high-energy physics folks). Although the system type wasn't recognized by the ifort installer, the install seemed to go ok and ifort is present and alive in /opt/intel/bin. However, the software paths don't seem to be configured properly. ie, when I run "ifort" from the command line, the shell responds that the command isn't found.

Running the config scripts doesn't seem to help, eg

[root@toulouse ~]# cd /opt/intel/bin/

[root@toulouse bin]# ./ifortvars.sh -arch intel64 -platform linux

[root@toulouse bin]# ifort

bash: ifort: command not found...

 

Also

[root@toulouse parallel_studio_xe_2019]# pwd

/opt/intel/parallel_studio_xe_2019

[root@toulouse parallel_studio_xe_2019]# ./psxevars.sh

Intel(R) Parallel Studio XE 2019 Update 2 for Linux*

Copyright (C) 2009-2019 Intel Corporation. All rights reserved.

[root@toulouse parallel_studio_xe_2019]# ifort

bash: ifort: command not found...

 

Any suggestions would be gratefully received.  Unfortunately, I can't switch to RHEL7 or Centos 7, although the system is functionally and configurationally equivalent.

 

0 Kudos
4 Replies
Highlighted
Valued Contributor I
72 Views

Hi Nathan,

if your ifortvars.sh lies in /opt/intel/bin, do you see a directory like /opt/intel/compilers_and_libraries_2019/linux/bin/intel64/ which some binaries inside? Is there a binary ifort? Can you execute that one? I think you just need to include /opt/intel/compilers_and_libraries_2019/linux/bin/intel64 into your $PATH environment. It seems this is not done by the ifortvars.sh.

Cheers,

    Juergen 

0 Kudos
Highlighted
Black Belt
72 Views

Two comments:

  1. The commands posted in #1 indicate that you are attempting to do Fortran development when logged in as root. Usually, this is not a wise choice, so it is to be hoped that you are aware of the implications of doing that.
  2. You have to "source" the shell script in order to have the settings persist for the duration of the current shell. You may either use "source " or ". " as a prefix to make this happen. There should be a space between the '.' and the shell script path/name; i.e., the command should be [. ./ifortvars.sh -arch intel64 -platform linux ] Without the space, the environment created in the shell script is lost as soon as the script is run, which is not what is wanted.
0 Kudos
Highlighted
Beginner
72 Views

Thanks for the conversation.  Per your suggestions, I took the approach of creating a one-line script in the /etc/profile.d/ folder.  This makes ifort available to all users on login.  Specifically, 

 

[root@toulouse ~]# cat /etc/profile.d/ifort.sh
# ntm, 2019-02-16 needed to get ifort available everywhere
. /opt/intel/bin/ifortvars.sh -arch intel64 -platform linux

 

This works, and it seems like less of a hack than simply pasting the same line at the end of my .bashrc file.  I'm still confused about why this wasn't done automatically by Intel's ifort installer.  

Also, Jurgen, yes, I'm not doing development as root!  Just installing ifort so I can compile a fast version of GAMESS for our students.  

0 Kudos
Highlighted
72 Views

Hi Nathan,

I have the same problem you have but with (version 2019, update 4), but i can not understand your solution. please make clear how ifort be available in .bashrc file and link it in

0 Kudos