Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
176 Views

error while loading shared libraries: libimf.so

Dear all I made a cluster with 2 nodes.

I installed openmpi with intel compilers and shared it via nfs and also the intel compilers are shared via nfs on each nodes.

when I try to run some applications on each nodes i found:

 

/opt/openmpi-1.6.5/bin/orted: error while loading shared libraries: libimf.so: cannot open shared object file: No such file or directory

--------------------------------------------------------------------------

A daemon (pid 18804) died unexpectedly with status 127 while attempting

to launch so we are aborting.

 

There may be more information reported by the environment (see above).

 

This may be because the daemon was unable to find all the needed shared

libraries on the remote node. You may set your LD_LIBRARY_PATH to have the

location of the shared libraries on the remote nodes and this will

automatically be forwarded to the remote nodes.

 

So I export in the .bash_profile of each nodes

export LD_LIBRARY_PATH=/opt/intel/lib/intel64:$LD_LIBRARY_PATH

source /opt/intel/bin/compilervars.sh intel64

export PATH=/opt/openmpi-1.6.5/bin:$PATH

export LD_LIBRARY_PATH=/opt/openmpi-1.6.5/lib:$LD_LIBRARY_PATH

 

But the problem is still the same I am not able to loading shared libraries : liibmf.so

 

Please can you help me to fix the problem?

 

Many thanks

lorenzo

0 Kudos
2 Replies
Highlighted
Beginner
176 Views

Sorry I'am running under

Sorry I'am running under Ubuntu 14.04.5 LTS on each nodes

Thanks again

lorenzo

0 Kudos
Employee
176 Views

You seem to be on the correct

You seem to be on the correct track. You have a bit of duplication in what you added to the .bash_profile. The source of the compilervars will establish the necessary environment variable settings including LD_LIBRARY_PATH so the initial export you added above that line would not be needed.

This FAQ contains exactly (Q #12) the scenario you are facing.

You need to try to determine whether the .bash_profile is invoked when your MPI job runs. Maybe you can drop an echo commend in there to see. You might echo the value of LD_LIBRARY_PATH after the commands to help verify its value.

Have you also confirmed you can run on either node interactively using a simple non-MPI hello_world Fortran program?

Sorry I don't have much direct advice on resolving this but again you seem on the correct path.

0 Kudos