Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28434 Discussions

failure of fortran oneAPI base+HPC to function

Ward_B_Watt
Beginner
1,023 Views

@Ron_Green  The attached 2pp file gives the history of my inability to get the referenced compiler to do its job, and an earnest plea for assistance.

Labels (1)
0 Kudos
7 Replies
Ron_Green
Moderator
1,015 Views

@Ward_B_Watt I had to remove your doc file as it had your license key.  We don't advise that as anyone could have attempted to steal it for their own use.  I saved my own copy, however.

 

It looks like an environment issue.  Once you have that window open, and you have run the vars batch file, do this command and capture the full output:

echo %PATH%

 

I will have more suggestions but first I need to charge my PC laptop.  

0 Kudos
Ron_Green
Moderator
997 Views

It appears you have both oneapi Base Toolkit and HPC Toolkit installed.  And yes, the "access denied" during the run of the batch script is a strong indicator of a problem.  Looks like maybe an error in the python kit.

 

So let's simplify

 

Uninstall all of Base Tookit and HPC Toolkit, HPC first, Base second.  Use Settings -> Apps -> Intel oneAPI * Toolkit -> uninstall

remove both.

 

This should leave you with VS2019 with just Microsoft C/C++ installed (you did install the C++ Component in VS 2019?)

Then just to be safe, reboot.

 

Next, read my article on installing JUST the Compilers:  

https://community.intel.com/t5/Intel-Fortran-Compiler/The-Easy-and-Fast-Way-to-Install-JUST-Fortran-with-Intel-oneAPI/m-p/1360571#M160118

 

and download and install JUST Fortran compilers.  Just this 1 package, no more at this time.

 

Now, open the special

'Intel oneAPI command prompt for Intel 64"

and NOT a Windows command prompt!

Do this from desktop:

Start -> Intel oneAPI 2022 -> Intel oneAPI command prompt for Intel 64 for Visual Studio 2019

 

in this window, try

ifort /V 

does that give the Ifort logo information and an error that no files specified?

0 Kudos
Ward_B_Watt
Beginner
935 Views

Thanks for your advice.  I do still get the error message that no file is specified. 

Here is the output from the echo %PATH% command,

:: initializing oneAPI environment...
Initializing Visual Studio command-line environment...
Visual Studio version 16.11.15 environment configured.
"C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\"
Visual Studio command-line environment initialized for: 'x64'
: compiler -- latest
: debugger -- latest
: mpi -- latest
:: oneAPI environment initialized ::

C:\Program Files (x86)\Intel\oneAPI>echo %PATH%
C:\Program Files (x86)\Intel\oneAPI\mpi\latest\env\..\libfabric\bin\utils;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\env\..\libfabric\bin;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\env\..\bin\release;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\env\..\bin;C:\Program Files (x86)\Intel\oneAPI\debugger\latest\env\\..\gdb\intel64\bin;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\bin;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\lib;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\bin\intel64;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\redist\intel64_win\compiler;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\\Extensions\Microsoft\IntelliCode\CLI;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.29.30133\bin\HostX64\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\VC\VCPackages;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\TestWindow;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\TeamFoundation\Team Explorer;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\bin\Roslyn;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Team Tools\Performance Tools\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Team Tools\Performance Tools;C:\Program Files (x86)\Microsoft Visual Studio\Shared\Common\VSPerfCollectionTools\vs2019\\x64;C:\Program Files (x86)\Microsoft Visual Studio\Shared\Common\VSPerfCollectionTools\vs2019\;C:\Program Files (x86)\Microsoft SDKs\Windows\v10.0A\bin\NETFX 4.8 Tools\x64\;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\FSharp\Tools;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\devinit;C:\Program Files (x86)\Windows Kits\10\bin\10.0.19041.0\x64;C:\Program Files (x86)\Windows Kits\10\bin\x64;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\\MSBuild\Current\Bin;C:\Windows\Microsoft.NET\Framework64\v4.0.30319;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\Tools\;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\bin\;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\bin\release\;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\libfabric\bin\;C:\Program Files (x86)\Intel\oneAPI\mpi\latest\libfabric\bin\utils\;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\redist\intel64_win\compiler;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\redist\ia32_win\compiler;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;c:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\dotnet\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Users\wattw\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Users\wattw\.dotnet\tools;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\CMake\CMake\bin;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\CMake\Ninja;C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\VC\Linux\bin\ConnectionManagerExe;C:\Program Files (x86)\Intel\oneAPI\compiler\latest\windows\lib\ocloc

 

Thanks for your help.

0 Kudos
JohnNichols
Valued Contributor III
919 Views

I have not counted the path lenght you have, but if it is over 260 characters, you may have problems.

 

https://www.thewindowsclub.com/how-to-enable-or-disable-win32-long-paths-in-windows-11-10 

 

i just counted it it is 3260 characters.  I would start there. 

 

Just a thought

 

 

0 Kudos
Ron_Green
Moderator
897 Views

can you find or create a 'helloworld.f90' program

compile with 

ifort  helloworld.f90

 

and attach the output.

next, same for this command

 

ifort -# helloworld.f90

0 Kudos
Ward_Watt
Beginner
485 Views

I am a molecular evolutionary geneticist (now “emeritus”, but still active) support period end 2023-09-29, license number etc. available to those authorized) for the Intel oneAPI base + HPC combined toolkit. It did not work. Being overworked myself, I could spare only limited time to struggle with it until recently, despite some kind suggestions from Ron Green centered on functional conflict between certain oneAPI Fortran releases and Microsoft Visual Studio, MVS being the source of the conflict.

 

My fundamental interest here is in being able to use the oneAPI compiler to program biological models, not to develop code features to begin with.  Accordingly, can you advise me which versions of oneAPI Fortran are functionally compatible with what is now hopefully a corrected version of MVS? If you can supply me with that advice on functional compatibility of the software in question, my problem will be solved.

0 Kudos
Steve_Lionel
Honored Contributor III
478 Views

The current version of the oneAPI HPC Toolkit (2023.1) works with the current version of Visual Studio 2022 or 2019. 

0 Kudos
Reply