Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
27770 Discussions

fatal error LNK1104: cannot open file 'ifconsol.lib'


I recently came up with this error while compiling a code:

fatal error LNK1104: cannot open file 'ifconsol.lib'

This error was listed in a post from 2006 ( ) and it seems to be the same kind of problem but I am using different tools and not sure how to fix it. Here is what's happening:

Someone from another company developed a code (as a DLL) using Intel Fortran 12.1 with Fortran 2003 standards. He was able to compile it using both Microsoft Visual Studio 2008 and 2010.

I took over the code and tried to compile with the latest version of Fortran (XE 2013) and Microsoft Visual Studio 2008. After having this error problem I checked and the library is available and in the correct directory. I do not know how to make the Makefile visible in Visual Studio but I tried to change some options without success. Then I tried to change the platform from Win32 to x64 (under the "buid" tab) to see what happens when compiling in 64 bits.

The compilation worked and I was able to run the code and compare the results (which were similar up to the 8th digit so within accuracy range).

I can use the 64 bits version and am happy with it, but does anyone have an idea on why the compilation does not work for 32 bits ?



0 Kudos
2 Replies

If you are building from Visual Studio, this means that the list of folders for library files is incorrect. Go into Tools > Options > Intel Visual Fortran > Compilers, make sure that the correct compiler version (or "Latest") is selected for the Win32 tab. Click on the Reset button and see if that helps.

Can you compile sources in this project? Forget about makefiles - Microsoft removed that.


Well, I did as you told me and the reset changed the order in the libraries list. And the compilation worked ! Exactly as you predicted.

Thanks a lot !