Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26733 Discussions

/fpp option seems to cause everything to recompile every time

Rumbaugh__Doug
Beginner
76 Views

I inherited some FORTRAN code and am using Intel(R) Visual Fortran Compiler 18.0.3.210 [Intel(R) 64] in Visual Studio 2017.  The source code requires the /fpp option because it contains #defines.  There is a lot of code and it takes a while to recompile.  The whole code base recompiles every time even when no changes have been made and it slow me way down.  What am I doing wrong?

Thanks in advance for a work around.

0 Kudos
3 Replies
Steve_Lionel
Black Belt Retired Employee
76 Views

Attach the .vfproj file from your project. It may give us a clue. Certainly this is not the usual behavior.

Rumbaugh__Doug
Beginner
76 Views

Here it is, thanks for taking a look.

Steve_Lionel
Black Belt Retired Employee
76 Views

I don't see anything obvious there. I don't think this has anything to do with enabling the preprocessor. Sometimes what helps is to exit VS, delete the .sln and .sou files from the solution folder, then restart VS. These are "hidden files" created by Visual Studio, so you may need to set the Windows Explorer option to show hidden files to see them.

I have seen others say that creating a new project (with the original source files) resolves the problem. Unfortunately Visual Studio does not expose the logic it uses for determining file dependencies so that one can see what it is doing.

Reply