Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
6 Views

ifort command fails after ifortvars.bat ia32 VS2015

Jump to solution

I've been working on making Fortran 32bit-application on Intel Fortran compiler, which I got as a part of Intel Parallel Studio XE 2017 for Windows(evaluation edition). Before installing it, Visual Studio 2015 Community had been already installed.

The steps I took is below:

1.Installed Visual Studio 2015 Community.
2.Installed Intel Parallel Studio XE 2017 Cluster edition for Windows.
3.Executed command:ifortvars.bat ia32 vs2015.
4.Executed command:`ifort.exe /dll test.f90`
5.Got an error:"'ifort.exe' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。 ", which means "'ifort.exe' is not recognized as an internal/external command nor an executable program nor bat file'".

In step4 I want to create 32bit-dll file, which is due to be used from the other 32bit-application.

I doubt the reason why step5 fails is that I have never succeeded in installing intel fortran 32bit compiler in step2.
Actually an option for selecting fortran 32bit-compiler was grayed out when installing.
If that's true, how can I get 32bit-compiler installed?

 

0 Kudos

Accepted Solutions
Highlighted
Retired Employee
6 Views

Please show the output of the

Jump to solution

Please show the output of the ifortvars.bat command.

My guess is that when you installed VS2015 Community you accepted the defaults, which omits the C++ components required by Intel Fortran. See https://software.intel.com/en-us/articles/installing-visual-studio-2015-for-use-with-intel-compilers for instructions.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran

View solution in original post

0 Kudos
2 Replies
Highlighted
Retired Employee
7 Views

Please show the output of the

Jump to solution

Please show the output of the ifortvars.bat command.

My guess is that when you installed VS2015 Community you accepted the defaults, which omits the C++ components required by Intel Fortran. See https://software.intel.com/en-us/articles/installing-visual-studio-2015-for-use-with-intel-compilers for instructions.

--
Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran

View solution in original post

0 Kudos
Highlighted
Beginner
6 Views

I'm sorry for being late for

Jump to solution

I'm sorry for being late for checking your response.
Actually reinstalling Parallel Studio enabled me to choose 32-bit compiler without reinstalling VS2015.
I will read the instructions you have taught. Thanks!

0 Kudos