Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
195 Views

ifort: error #10037: could not find 'link'

I have recently acquired a copy of Microsoft Visual Studio 2012 and Intel Parallel Studio Visual Fortran Compiler XE 2013.

When I attempt to run a simple Fortran Program through the command prompt, I get the following error message

ifort: error #10037: Could not find 'link'

I don't really think this is an installation issue. This was how my installation procedure went:

1) Install Intel Parallel Studio XE 2013

2) Install Microsoft Visual Studio 2012

3) Uninstall Intel Parallel Studio XE 2013

4)Re-install Intel Parallel Studio XE 2013

The reason for steps 3) and 4) was that I could not see Fortran project types in Visual Studio after step 2). Steps 3) and 4) fixed this.

I would much rather fix this without having to install, uninstall or repair any of the above software. Thanks.

 

 

 

0 Kudos
22 Replies
Highlighted
Employee
190 Views

The installation order is Microsoft Visual Studio followed by Parallel Studio XE. The cause could be that you are missing the C++ Development component of Visual Studio. For that I can't advise you on how to fix without using the modify/repair feature of Visual Studio to install the missing component. This article has some information about how to check for that. 

0 Kudos
Highlighted
New Contributor I
190 Views

This is the permanent state for me at the commant prompt because I use the VS2013 community edition. However the problem is just setting up the path so if you start an ifort command window and then run

"C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\vcvarsall.bat" x86_amd64

you should find that you can link in the command window.

0 Kudos
Highlighted
Valued Contributor III
190 Views

Under the " Intel Parallel Studio XE20xx" strat menu entry you will find shortcuts that create 32 or 64 bit cmd prompts that are set up correctly.

0 Kudos
Highlighted
New Contributor I
190 Views

Well they're not on mine, but as I said I think that's because I'm using the community edition of VS 2013.

0 Kudos
Highlighted
Employee
190 Views

The shortcuts mentioned should exist and function with VS 2013 Community. You could perhaps repair those by running the Repair for Intel Parallel Studio XE, or stick with what is working for you.

0 Kudos
Highlighted
Beginner
190 Views

@Andrew_4619

It doesn't matter what command prompt I use, I still have the exact same problem. I have tried all of the following prompts:

1) IA-32 Visual Studio 2012 Mode

2) Intel 64 Visual Studio 2012 Mode

3) Developer command prompt for Visual Studio 2012

Furthermore all these prompts show an additional error message upon opening:

ERROR: Cannot find VS Common tools folder

Please note I have tried to fix the above error by adding the C:\Windows\System32 path to the PATH environment variable and this did not change anything. Thanks.

 

 

0 Kudos
Highlighted
Black Belt Retired Employee
190 Views

Your last post gives a clue - The Visual Studio environment setup is not finding a valid VS installation.

I suggest doing this:

  1. Uninstall Intel Parallel Studio XE
  2. Do a "Repair" on Microsoft Visual Studio (rerun the VS 2012 installer or select Change/Modify from Control Panel > Programs and Features)
  3. Reinstall Intel Parallel Studio XE

 

0 Kudos
Highlighted
Beginner
190 Views

@Simon Geard. I tried running the vcvarsall.bat file but got the following error:

ERROR: Cannot determine the location of the VS Common Tools folder

0 Kudos
Highlighted
Black Belt Retired Employee
190 Views

I suggest that you reinstall Visual Studio, making sure that the C++ support is selected. It is not the default in VS2015 or VS2017.

0 Kudos
Highlighted
Beginner
190 Views

I already did that Steve, uninstall, repair. the whole deal. Besides I am using VS 2012 which does have Visual C++ support. Also, I need solutions which do NOT assume that I have administrative rights to my machine. This is company policy and will likely not change

Capture.JPG

0 Kudos
Highlighted
Valued Contributor III
190 Views

So was VS installed without administrator rights? I would be surprised if that would work well.

0 Kudos
Highlighted
Black Belt Retired Employee
190 Views

From a plain command prompt, please show the output of:

set vs

0 Kudos
Highlighted
Beginner
190 Views

Heres what it says:

 

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\aboufira>set vs
VS110COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Tools
\

C:\Users\aboufira>

 

0 Kudos
Highlighted
Black Belt Retired Employee
190 Views

Ok. Now do:

DIR %VS110COMNTOOLS%

and show the output

0 Kudos
Highlighted
Beginner
190 Views

Heres what that does:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.


C:\Users\aboufira>DIR %VS110COMNTOOLS%
The system cannot find the file specified.

C:\Users\aboufira>

 

0 Kudos
Highlighted
Black Belt Retired Employee
190 Views

Sorry, my error. Try this:

DIR "%VS110COMNTOOLS%"

0 Kudos
Highlighted
Beginner
190 Views

Heres what that does...

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\aboufira>
C:\Users\aboufira>
C:\Users\aboufira>DIR "%VS110COMNTOOLS%"
 Volume in drive C is OS
 Volume Serial Number is 944A-AABE

 Directory of C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Tools

17-Mar-17  09:38    <DIR>          .
17-Mar-17  09:38    <DIR>          ..
17-Mar-17  09:38    <DIR>          1033
12-Dec-11  14:37            11,197 AtlTraceTool8.chm
26-Jul-12  20:08            68,064 AtlTraceTool8.exe
16-Mar-17  11:24    <DIR>          bin
26-Jul-12  20:08            17,872 devcmdmui.dll
16-Mar-17  11:01    <DIR>          en-US
26-Jul-12  20:08            53,704 errlook.exe
12-Dec-11  14:36             7,427 errlook.hlp
30-Oct-13  01:28            40,608 guidgen.exe
30-Oct-13  01:28            34,456 makehm.exe
17-Mar-17  09:38    <DIR>          ProjectComponents
29-Aug-13  20:55            21,525 Rules2BuildRules.xslt
29-Aug-13  20:55             8,080 Rules2Props.xslt
29-Aug-13  20:55            11,171 Rules2Targets.xslt
12-Dec-11  14:30           115,559 spyxx.chm
26-Jul-12  20:08           696,768 spyxx.exe
26-Jul-12  20:08           168,904 spyxxhk.dll
26-Jul-12  16:22           185,312 spyxxhk_amd64.dll
12-Dec-11  14:30           115,559 spyxx_amd64.chm
26-Jul-12  16:22           970,200 spyxx_amd64.exe
30-Oct-13  01:28           270,528 vcconvertengine.dll
26-Jul-12  20:08           380,920 VCProjectConversion.dll
30-Oct-13  01:28            57,000 vcupgrade.exe
26-Jun-13  20:49             1,084 vcupgrade.exe.config
29-Aug-13  20:55            10,321 VCVarsQueryRegistry.bat
16-Mar-17  11:01    <DIR>          VDT
05-Jun-12  23:12             4,450 VsDevCmd.bat
29-Aug-13  20:55             4,452 vsvars32.bat
              23 File(s)      3,255,161 bytes
               7 Dir(s)  125,971,865,600 bytes free

C:\Users\aboufira>







 

0 Kudos
Highlighted
Black Belt Retired Employee
190 Views

Ok, I think I know what the problem is. Your administrator has locked down the system so much that attempts to read the registry are blocked from command line tools. The Visual Studio initialization uses a tool to read from the registry, and I have seen others report similar problems when that tool is blocked. It is not simply lacking administrator privilege.

Solving this is tricky. You could manually add the needed MSVC folders to PATH and LIB. It might also be possible that if you uninstalled Fortran and VS, deleted the Microsoft Visual Studio 11.0 folder from Program Files (86), then reinstalled Fortran and allow it to install the VS2010-based Fortran environment (assuming you don't have a Student license), it would work.

0 Kudos
Highlighted
Beginner
190 Views

I see. Regarding the options you have suggested:

Option 1: manually add the needed MSVC folders to PATH and LIB

How do I go about this? Any previous threads or specific instructions I can follow?

Option 2: uninstall Fortran and VS, delete the Microsoft Visual Studio 11.0 folder from Program Files (86), then reinstall Fortran and allow it to install the VS2010-based Fortran environment

This is my preferred option and I have a feeling it might work. However it would require me to downgrade VS which is a bummer. I will attempt this over the weekend and give you an update on how it goes..

0 Kudos