Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

ifort

Guaglardi__Paul
Beginner
119 Views

Was compiling and running fine for some time.

All of a sudden, I am getting this warning.

1>ifort: warning #10182: disabling optimization; runtime debug checks enabled
1>GPS_MAIN_EXE.F90
1>Linking...
1>Embedding manifest...

I cannot turn on optimization (off the debug) under any circumstances.

I used to have the optimization enabled all of the time ad indirectly enable the debugger through the RUN TIME stack frame and array bounds.

Now, nothing works.

HELP!

0 Kudos
3 Replies
Steve_Lionel
Black Belt Retired Employee
119 Views

What did you change? New compiler version?

It's the stack checking that is inconsistent with optimization. Turn that off. I assume you realize that debugging optimized code can be difficult since the debugger has little idea where things are.

Guaglardi__Paul
Beginner
119 Views

Hi Steve, thanks for your input but the stack checking is disabled.  Something has changed on own and it is confusing.  The only thing I did do was create some static arrays.

Steve_Lionel
Black Belt Retired Employee
119 Views

Please zip the buildlog.htm from the Debug or Release folder (after doing a Rebuild on the project) and attach it here.

Reply