Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.

problem created by latest INTEL / VS update - lost Fortran compiler!


Hi all,

I have updated my INTEL software to the latest version ("Intel System Studio 2018 Update 2 Ultimate Edition for Windows". As a result of this update, I've immediately lost the Fortran compiler in VS.

Until this update, it worked perfectly. The C++ support is present.

I think it somehow lost integration. Am getting the error message, however the integration files are in the correct folders:

1>------ Build started: Project: <_my project name_> Configuration: Debug x64 ------
1>The Fortran compiler (ifort.exe) cannot be found.
So far, I have:
- tried to "repair" the Intel visual studio - no use
- tried using the "reset" button in the VS preferences, Fortran tab - no use
- uninstalled all of Fortran compilers (INTEL visual studio)
- reinstalled it (twice so far...) - both 32 and 64 versions, my computer is x64, but just in case
including de- and re-registering the integrate.bat process, via the command line (yes, with Admin privileges.)
- rebooted after every one of these attempts
Hasn't made any difference. Still the same error.
I don't know if this makes any difference, but in VS the compiler is described as "Intel(R) Visual Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, version 18.0.3 Package ID: w_comp_lib_2018.3.210" 
but the properties of the VFProj.dll in C:\Program Files (x86)\Common Files\Intel\shared files\VS Integration\VS15\Intel Fortran\VFPackages
says it's
Which is frankly weird, because I've just reinstalled that compiler twice.
Any thoughts about what I should do next? I am quite upset about this happening, as my project is due in a few days, and I really need this to work... and it was just a software update!
Thanks beforehand!
0 Kudos
3 Replies
Honored Contributor III

Intel System Studio and Intel Parallel Studio are two substantially different products that are often confused for each other (just as IA64 and Intel64 are confused for each other). System Studio is for cross-development for Things and embedded devices; it does not provide a Fortran compiler. The package that you want is one of the shades of Parallel Studio. 

0 Kudos

Yes, I understand that. But installing the System Studio still broke my Visual Studio compiler...  And reinstallihg the visual studio doesn't fix it.

0 Kudos
Honored Contributor III

In Tools > Intel Compilers and Tools > Visual Fortran > Compilers, x64 tab, click on the ... next to Executables. Copy all the text shown and paste it into a reply here. It should look something like this:


What does yours have?

0 Kudos