Intel® Graphics Performance Analyzers (Intel® GPA)
Improve your game's performance by quickly identifying problem areas.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
452 Discussions

GPA frame analyzer can't open a frame and popup a message "An internal error has occurred ..."

RussellLuo
Beginner
197 Views

Recently I find that GPA can't open frame I captured and popup a ERROR message as follows.

RussellLuo_0-1673850259312.png

I reinstall my os, it works. However, it failed again after a few days. It's annoyed me very much.

I have checked the log file in "C:\Users\***\Documents\GPA\Logs\FrameAnalyzer". The GPA try to bind listener socket to port from 1112 to 1211 and all failed with error code 10013.

How can I fix the problem!

 

The necessary information of my environment as follows:

Operating System:
Name: Windows 10 Version 2009 (OS Build 22621.1105)
Locale: zh-CN
Secure Boot/Trusted Boot is disabled

CPU Information:
Name: 12th Gen Intel(R) Core(TM) i7-12700KF
Architecture: x64
Cores count: 20

System BIOS:
Version: American Megatrends Inc. 0605
Date: 11/12/2021

GPU Information:
Name: NVIDIA GeForce RTX 3050
Vendor id: 0x10DE
Product id: 0x2507
Stepping: 161
Driver Version: 31.0.15.1740
Driver Date: 9-12-2022

Machine:
Name: ****
Memory: 32577 MB
Screen: 2560x1440, 32 bit

Graphics Performance Analyzers:
Version: 22.4.1671013788
Commit hash: bb72c912
Installation folder: C:\Program Files\IntelSWTools\GPA\

The attachment is log file.

Labels (1)
0 Kudos
1 Solution
RussellLuo
Beginner
172 Views

I have fixed problem by myself.

The reason is the ports (from1112 to 1211) used by gpa are reserved when I enable Hyper-V. You can fix the problem as follow steps.

1. Open cmd.exe as administrator.

2. Disable Hyper-V and reboot.

   dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

3. Set dynamic port as a larger number than 1211.

    netsh int ipv4 set dynamicport tcp start=1250 num=16383

    If we set dynamic port number start from 1250, the windows will not reserve port small than it after enable Hyper-V.

4. Enable Hyper-V and reboot again.

   dism.exe /Online /Enable-Feature:Microsoft-Hyper-V /All

 

You can find more by about dynamic port in https://learn.microsoft.com/en-US/troubleshoot/windows-server/networking/default-dynamic-port-range-...

 

I hope it will be helpful for someone who encounter the same problem.

View solution in original post

2 Replies
RussellLuo
Beginner
173 Views

I have fixed problem by myself.

The reason is the ports (from1112 to 1211) used by gpa are reserved when I enable Hyper-V. You can fix the problem as follow steps.

1. Open cmd.exe as administrator.

2. Disable Hyper-V and reboot.

   dism.exe /Online /Disable-Feature:Microsoft-Hyper-V

3. Set dynamic port as a larger number than 1211.

    netsh int ipv4 set dynamicport tcp start=1250 num=16383

    If we set dynamic port number start from 1250, the windows will not reserve port small than it after enable Hyper-V.

4. Enable Hyper-V and reboot again.

   dism.exe /Online /Enable-Feature:Microsoft-Hyper-V /All

 

You can find more by about dynamic port in https://learn.microsoft.com/en-US/troubleshoot/windows-server/networking/default-dynamic-port-range-...

 

I hope it will be helpful for someone who encounter the same problem.

Pamela_H_Intel
Moderator
142 Views

Wonderful Russell! Thank you so much for posting the workaround.


Reply