Intel® Graphics Performance Analyzers (Intel® GPA)
Improve your game's performance by quickly specifying problem areas
472 Discussions

Graphics Monitor Crashes Upon Opening of UE4 Game



I have found exactly same problem as this


  • UE4 4.17 _standard out the box first person shooter game_ Packaged game_this runs.
  • GPA 2017 R2
  • System_Windows PC 8.1 / 64 bit / i7 / NVIDIA Quadro K1100M (please check attached About Details File)

Steps taken

  1. Package the game for Win x64 (my machine is a 64-bit PC)
  2. Run GPA
  3. Look for the executable through the GPA UI
  4. Select the desired command (executable) and click on 'Run'
  5. The game will load with the GPA Gizmo at upper left corner, as if it's frozen, but as soon as I see the image of my test scene, the process would crash, leaving me an UE crash windows that basically says it can't show me any log trace because the executable isn't set up for debugging (I'm packaging for development, by the way.
  6. After I close the UE crash window, I'd get a Windows notification from GPA saying that it "failed to attach to process", hence I'm guessing it's crashing when trying to link with my build. GPA will still be running, for the record. Also, if I try to run my build without GPA, it will run without issues

Attempts to Troubleshoot:

  • Updated gfx drivers - Geforce - Intel
  • tested on Geforce  and Intel independently by disabling
  • attempted injection  (Auto-detect launched applications)
  • Re installed both UE4 and GPA
  • Windows Refresh and only installed installed both UE4 and GPA

Thank you in advance

0 Kudos
2 Replies


Restart machine following disable of specific gfx card. 

However this is a workaround. and requires restart each time switching from game dev / GPA.

0 Kudos

Hey Karl, 

Thank you for posting what worked for you. The forum topic that you posted looks like it was "solved" using the same workaround. Unfortunately there is currently no "permanent" solution that doesn't require the restart of your computer. 

0 Kudos