Intel® Graphics Performance Analyzers (Intel® GPA)
Improve your game's performance by quickly identifying problem areas.

Stream Capture is not starting applications

AndresIbanez
Beginner
1,276 Views

Currently experiencing issues with opening applications to Stream capture. There are multiple game applications that were tried to run and none have worked. Some of these applications worked previously before most recent 21.3 . Frame Capture works, Trace and stream does not. Extended Profiling modes was enabled to check DX11, DX12 and Vulkan. None worked.

  • All applications were x64.
  • All applications were run first and enabled for the firewall
  • GPA server was enabled for firewall
  • GPA frameworks was updated to 21.3
  • Drivers were updated

 

Operating System:
    Name: Windows 10 Version 2009 (OS Build 19043.1237)
    Locale: en-150
    Windows Developer Mode is enabled
    Secure Boot/Trusted Boot is disabled

CPU Information:
    Architecture: x64
    Cores count: 16

System BIOS:
    Version: American Megatrends International, LLC. F4
    Date: 06/15/2021

GPU Information:
    Name: NVIDIA GeForce RTX 3070 Ti
    Vendor id: 0x10DE
    Product id: 0x2482
    Stepping: 161
    Driver Version: 30.0.14.7212
    Driver Date: 9-13-2021

Machine:
    Name:
    Memory: 32633 MB
    Screen: 2560x1440, 32 bit

Graphics Performance Analyzers:
    Version: 21.3.1632323082
    Commit hash: b5b99390
    Installation folder: C:\Program Files\IntelSWTools\GPA\

0 Kudos
5 Replies
Pamela_H_Intel
Moderator
1,223 Views

Andres,

For clarification:

  • using Graphics Monitor, you can capture a Frame, but not a Stream nor a Trace
  • you say you updated GPA Framework, have you tried doing a capture with that?

Pamela

AndresIbanez
Beginner
1,207 Views

So I understand correctly, are we not supposed to "start" applications through the graphics monitor?

The options used to work before the new patch to the Intel GPA tool. Are we no longer supposed to open the game through these options, but instead through framework?

Thank you,

Andres

Pamela_H_Intel
Moderator
1,192 Views

Andres,

Absolutely, yes. If you are using the GPA GUI tools - Graphics Monitor, System Analyzer, Graphics Trace Analyzer, Graphics Frame Analyzer, then you can capture either in System Analyzer or Graphics Monitor. Graphics Monitor allows you to set lots of options, so that is usually where I start. And we do want to know if there is an issue that we need to address.

But meanwhile, if you are having any sort of frame capture issue with the GUI tools, you can try using GPA Framework. Framework will capture a Stream, and with options you can capture a certain number of frames.

Here are the options I most often use (run from C:\Program Files\IntelSWTools\GPA Framework\21.3\bin\Release):

capture
gpa-injector C:\Program Files\IntelSWTools\GPA\gpasample.exe --layer capture
gpa-injector --layer capture “C:\Program Files\IntelSWTools\GPA\gpasample.exe”
+HUD
gpa-injector -L hud-layer -L capture:deferred=true “C:\Program Files\IntelSWTools\GPA\gpasample.exe”
+defer
gpa-injector -L hud-layer -L capture:deferred=true “C:\Program Files\IntelSWTools\GPA\gpasample.exe”
+frameCount
gpa-injector -L hud-layer -L capture:deferred=true,fixed-frame-count=10 “C:\Program Files\IntelSWTools\GPA\gpasample.exe”
+destination dir
gpa-injector -L hud-layer --layer capture:directory=“C:\Users\pamelaha\GPA” “C:\Program Files\IntelSWTools\GPA\gpasample.exe”

There are several more options.

Pamela

AndresIbanez
Beginner
1,158 Views

Hello Pamela,

I apologize for the late reply, there does seem to be an issue with the graphics monitor application on my computer, it is currently not launching applications through the Graphics monitor, but I can run streams through it detecting launched applications. The framework tool is working as intended. I appreciate the help.

Thank you,

Andres

Pamela_H_Intel
Moderator
1,144 Views

Andres,

So it sounds like you are getting by with GPA Framework.

But also, I would like to try to reproduce your issue with Graphics Monitor. I imagine your scenario is as follows (correct me where your workflow differs):

  1. you successfully open Graphics Monitor
  2. your game shows in the window (or you can seek the directory and find the exe file)
  3. you can select Stream mode on the bottom right of the Graphics Monitor window
  4. you can select stream options from the Options button on the bottom left of the window (then the Stream tab)
  5. you have the "Auto detect launched applications" setting disabled (OFF)
  6. you click the "play" triangle on your game icon in the Graphics Monitor window (or, if it's not there because you haven't run it through Graphics Monitor before, you hit the Start button to the right of the Stream mode selection on the bottom right of the window)
  7. You wait, but never see the capture window?
  8. Could the capture window be offscreen? Did the "play" icon triangle change to a running circle? Then did it change to a "stop" icon square? If it changed to a square then your game is running somewhere. If that's the case, do you sometimes attach and detach from a secondary monitor?

It sounds like GPA is not new to you, but I'm not certain, so here is an image pointing out the items I refer to:

GraphicsMonitorParts.png

Reply