Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
561 Discussions

Devcloud: unable to run designs on Stratix10 nodes

kkvasan
Beginner
627 Views

Hi All, 

I am getting following error when trying to run https://github.com/intel/FPGA-Devcloud/tree/master/main/QuickStartGuides/OneAPI_Program_PAC_Quicksta...  on stratix 10 FPGA node.

./vector-add-buffers.fpga
Error: The accelerator hardware currently programmed is incompatible with this
version of the runtime (v2021.4.0 Build 157.4). Please recompile the hardware with
the same version of the compiler and program that onto the board.

acl_hal_mmd.cpp:882:assert failure: Failed to initialize kernel interfacevector-add-buffers.fpga: acl_hal_mmd.cpp:882: int l_try_device(unsigned int, const char*, acl_system_def_t*, acl_mmd_dispatch_t*): Assertion `0' failed.
Makefile.fpga:41: recipe for target 'run_hw' failed
make: *** [run_hw] Aborted

 

 

for the note, I was able to successfully run on A10 nodes.

 

I reported the same issue yesterday, but for some reason it is classified as spam and taken away.


Many Thanks,
Vasan



0 Kudos
1 Solution
BoonBengT_Intel
Moderator
592 Views

Hi @kkvasan,

 

Thank you for posting in Intel community forum and hope all is well.
Noted on the guide link provided, mind if I ask in which node are you having the problem?
And what are the command/steps in the guide that you are having issues with?

 

Would recommend to try the devcloud_login command to go to child node with appropriate hardware to run to command which sometime are the cause of the error above mentioning on hardware issues.
Hope that clarify.

 

Best Wishes
BB

View solution in original post

4 Replies
BoonBengT_Intel
Moderator
593 Views

Hi @kkvasan,

 

Thank you for posting in Intel community forum and hope all is well.
Noted on the guide link provided, mind if I ask in which node are you having the problem?
And what are the command/steps in the guide that you are having issues with?

 

Would recommend to try the devcloud_login command to go to child node with appropriate hardware to run to command which sometime are the cause of the error above mentioning on hardware issues.
Hope that clarify.

 

Best Wishes
BB

kkvasan
Beginner
580 Views

Hi BB, 

Thanks for the reply. 
Later I tried using devclou_login and selected the node. 
The initial compilation was targetted the pac_s10 but later realized is the board in the s001-n143 node is pac_s10_usm. 
Now I am able to run on S10 node.  

Many Thanks, 
Vasan

BoonBengT_Intel
Moderator
569 Views

Hi @kkvasan,

 

Great! Good to know that it is working now, with no further clarification on this thread, it will be transitioned to community support for further help on doubts in this thread, where we will no longer monitor this thread.
Thank you for the questions and as always pleasure having you here.

 

Best Wishes
BB

kkvasan
Beginner
504 Views

Hi BB, 

Hope you are doing good. 
Today I am again not able to run applications on Stratix 10 oneapi nodes. 
I tried all S10 oneapi nodes, but everything giver similar error as follows, 

Error enumerating AFCs: not found 
Segmentation fault 

tried fpgainfo as well, it also says 
Error enumerating resources: not found 

Is it that, the static region is updated or requires some tool setup? 

Many Thanks, 
Vasan


Reply