Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
673 Discussions

HLS run Quartus compile FAILED with following error "qsh_flowengine.tcl" unsuccessful

Desani
Beginner
2,272 Views

error "qsh_flowengine.tcl" unsuccessful

0 Kudos
14 Replies
BoonBengT_Intel
Moderator
2,247 Views

Hi @Desani,


Thank you for posting in Intel community forum and hope all is well.

Mind if I asked which example design did you tried to compile on?

And it would be helpful to let us know what are the command that you run to get the error?


My guess you are trying to compile and generate the IP and there are some issues on the quartus tcl script.

If its convenient if you can also share the screenshot of the error logs to help understand further.

Looking forward for you reply.


Best Wishes

BB


0 Kudos
jlrainbolt
Beginner
2,218 Views

Hello,

We tried to compile "tutorials/best_practices/optimize_ii_using_hls_register" on a Linux machine.

When I run "make" I get this message in the terminal:

i++ -march=Arria10 --quartus-compile -ghdl part_1_implemented_using_memory_module.cpp -o part_1_implemented_using_memory_module
HLS run Quartus compile FAILED.
See /home/jlrainbolt/tutorials/best_practices/optimize_ii_using_hls_register/part_1_implemented_using_memory_module.prj/debug.log for details.
make: *** [part_1_implemented_using_memory_module] Error 1

In "part_1_implemented_using_memory_module.prj/debug.log" (attached), the error message is

Error (23031): Evaluation of Tcl script /opt/intelFPGA_pro/21.4/quartus/common/tcl/internal/qsh_flowengine.tcl unsuccessful

If I open "part_1_implemented_using_memory_module.prj/quartus/quartus_compile.qpf" in Quartus and press the play button, the compilation fails with no error messages shown (as in the attached screenshot).

Thank you!

 

 

0 Kudos
BoonBengT_Intel
Moderator
2,213 Views

Hi @Desani,


My guess is there are some setup issues in Quartus which cause the HLS compilation for IP to failed.

Would recommend to check on the following below:

1) As compilation are for Arria10 devices, please check if Quartus have that device installed. (creating an empty project with arria10 devices)

2) Ensure if simulation tool are also installed as sometime it will cause certain failure compilation.

3) Running the 'init_hls' to check on the Linux machine setup.

4) If all failed, would suggest to reinstalled by following this sequences 1)Quartus 2)Desire device 3)HLS compiler


Hope that clarify.


Best Wishes

BB


0 Kudos
BoonBengT_Intel
Moderator
2,182 Views

Hi @Desani,


Greetings, just checking in to see if there is any further doubts in regards to this matter.

Hope we have clarify your doubts.


Best Wishes

BB


0 Kudos
jlrainbolt
Beginner
2,172 Views

Hello BB,

 

Thanks for checking in.  The problem hasn't been solved yet.  Regarding your suggestions,

  1. I was able to create a project with Arria10 devices
  2. QuestaSim is installed
  3. Running init_hls.sh shows that all of the steps were successful (shown in the attached logfile)
  4. I haven't had the chance to try reinstalling.

Thank you,

Lacey

0 Kudos
BoonBengT_Intel
Moderator
2,129 Views

Hi @jlrainbolt,


After analyzing the init_hls logs, it seems that the setup are ok.

However after revisiting the previous debug logs, my suspect here is that the fitter in quartus crushes might be due to RAM limit, hence would recommend to also checked on the memory usage for your compilation machine.


Would recommend to reboot your machine and launched another compilation, and monitor the RAM usage, at the same time try to free up or minimiza the RAM usage for your compilation machine when the compilation happens.


Note: Sometime placement and routing processes might be memory intensive.


Best Wishes

BB


0 Kudos
jlrainbolt
Beginner
2,104 Views

Hi @BoonBengT_Intel ,

 

Thank you for this suggestion.  I rebooted the computer and ran the tutorial exactly as I did in this post while monitoring the RAM usage.  The system RAM usage topped out at 9 GB.  The computer has 125 GM of RAM, so unfortunately I don't think this is the problem.

 

Thank you,

Lacey

0 Kudos
Kenny_Tan
Moderator
2,064 Views

Hi,


Since this issue is complex, we will need about 2 weeks or more to investigate this.


Kindly stay tune and once we got the answer, we will reply asap.


Thanks


0 Kudos
BoonBengT_Intel
Moderator
2,007 Views

Hi @jlrainbolt,


We have tried the running the mention example on our environment and are able to build them accordingly.

Quick check, what OS are you running it on and which HLS and Quartus version us being used?

Hope to hear from you soon.


Best Wishes

BB


0 Kudos
jlrainbolt
Beginner
1,925 Views

Hello @BoonBengT_Intel ,

 

Sorry for the delay (I was out sick with covid).  Our machine is running Red Hat Enterprise Linux Server version 7.9 (Maipo) and the Quartus version is 21.4.

 

Thank you,

Lacey

0 Kudos
BoonBengT_Intel
Moderator
1,997 Views

Hi @jlrainbolt,


Good day, just following up on the previous clarification.

By any chances did you managed to look into the it?


Best Wishes

BB


0 Kudos
BoonBengT_Intel
Moderator
1,976 Views

Hi @jlrainbolt,


Following up on the previous clarification.

Any chances did you managed to look into this request?


Best Wishes

BB


0 Kudos
BoonBengT_Intel
Moderator
1,902 Views

Hi @jlrainbolt,


Noted on the OS and Quartus version mention, hope all is well from your end.

Back to the issues, I believe you are using the same HLS version 21.4 pro.


My guess is are still suspecting the host machine, by any chances did you managed to try on other version of Quartus and HLS? Or perhaps have another host machine avaialbe to try on the version 21.4 pro mention?


This is just so that we can narrow down the possible issues here.

Hope to hear from you soon.


Best Wishes

BB


0 Kudos
jlrainbolt
Beginner
1,888 Views

Hi @BoonBengT_Intel ,

 

I have also tried versions 20.2 and 21.2 on the same system.  21.2 has the same problem as 21.4, but when I use 20.2 the error doesn't occur.

 

I don't know offhand if we have another Linux machine available to install 21.4, but I can find out.

 

Thanks,

Lacey

0 Kudos
Reply