Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DRuiz9
Novice
571 Views

PCIe x16 does not recognize Altera Cyclone V in Centos 7

Hello everyone.

 

I am trying to configure a Cyclone V on Centos 7 through the PCI Express 16 port and the FPGA does not recognize me. The FPGA port is 4x. I currently have another PCI Express 16 port busy with a graphics card and it does. I have tried to change the FPGA in the port of the graphics card and it continues without recognizing it, but it does recognize me in the other port the graphics card, so I deduce that it is a hardware problem at the level of the motherboard ... I have checked the switch configurations in the FPGA and the configuration corresponds to that recommended for the PCI Expres 4x: SW5 x1 = off, x4 = on. JP8 & JP10 in 1 and 2 and JP1 in 7 and 8.

 

To determine that the FPGA port does not recognize me, I have made the query: "sudo dmidecode -t 9". I have also configured in the BIOS the port where I have the FPGA for "Gen1" since it indicates that the port is a "PCIe Gen1 x4", but still, the BIOS tells me that there is nothing in that slot ...

 

I have followed the installation documentation rigorously, but the problem is that it does any PCI Express detect the FPGA...

 

Information about the motherboard:

Getting SMBIOS data from sysfs. SMBIOS 2.7 present.   Handle 0x0002, DMI type 2, 15 bytes Base Board Information Manufacturer: ASUSTeK COMPUTER INC. Product Name: P8H77-M Version: Rev X.0x Serial Number: 120901894802459 Asset Tag: To be filled by O.E.M. Features: Board is a hosting board Board is replaceable Location In Chassis: To be filled by O.E.M. Chassis Handle: 0x0003 Type: Motherboard Contained Object Handles: 0  

 

I put the images with all the information of the bash console.

 

"aoc -list-boards" command:

Captura de pantalla de 2019-08-08 00-35-52.png

 

 

 

 

"aocl install" command:

Driver_Install.png

 

 

 

 

"sudo dmidecode -t 9" bash command:

Captura de pantalla de 2019-08-08 01-54-14.png

 

 

 

 

and finally, "aocl diagnose" command:

Captura de pantalla de 2019-08-08 03-01-20.png

 

 

 

 

When try to compile "hello_world" program, the output is:

Captura de pantalla de 2019-08-08 00-36-15.png

 

 

 

 

In Windows the device does not recognize me either, although I have not tried to install or configure anything, just start on windows with the FPGA on.

 

Is it possible that it is a factory failure?

 

Regards thank you very much ! ;)

 

P.D: Sorry for the images, next time will put code directly, I'm a newer here!

 

0 Kudos
3 Replies
HRZ
Valued Contributor II
161 Views

Interesting, I had never seen a PCI-E-based Cyclone V board before. I guess you are using the Terasic OpenVINO Starter Kit, right?

 

Anyway, Have you followed Terasic's instructions for getting OpenCL to work with your board? Specifically, you first need to program the board through JTAG with an OpenCL image to enable the PCI-E core on the FPGA and then reboot your machine for the board to be detected via PCI-E. It won't be detected out of the box.

 

DRuiz9
Novice
161 Views

Indeed, it is about Terasic OpenVINO. I have looked at the Terasic page and had not seen more documentation, but I will search more thoroughly. In reference to your comment, I found this, which deals with what you have just commented.

 

https://forums.intel.com/s/question/0D50P00003yyHSWSA2/i-have-some-error-to-use-opencl-please-help-m...

 

Regards thank you very much!

 

HRZ
Valued Contributor II
161 Views

I believe you should have seen the "OpenCL User Manual" here already:

 

https://www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=167&No=1159&PartNo=4

 

I think your main problem is that either you have not correctly connected the JTAG cable (or connected it at all), or the cable is not being detected for some reason and hence, the aocl flash command which is supposed to enable the PCI-E core is failing. That is the problem you should focus on solving right now.

Reply