Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
52 Views

Bad start - ipptest.cpp doesn't compile

I just installed the community version of ipp_2017.0.098. and am trying the ipptest.cpp sample code on the Getting Started page and I'm getting the following errors on Centos 6, with gcc 4.4:

g++  ipptest.cpp -o ipptest -I $IPPROOT/include -L $IPPROOT/lib/intel64 -lippi -lipps -lippcore
ipptest.cpp: In function ‘int main(int, char**)’:
ipptest.cpp:56: error: ‘ippCPUID_SHA’ was not declared in this scope
ipptest.cpp:62: error: ‘ippCPUID_RDRAND’ was not declared in this scope
ipptest.cpp:71: error: ‘ippCPUID_AVX512F’ was not declared in this scope
ipptest.cpp:74: error: ‘ippCPUID_AVX512CD’ was not declared in this scope
ipptest.cpp:77: error: ‘ippCPUID_AVX512ER’ was not declared in this scope
ipptest.cpp:80: error: ‘ippCPUID_ADCOX’ was not declared in this scope
ipptest.cpp:83: error: ‘ip’ was not declared in this scope
ipptest.cpp:83: error: expected ‘)’ before ‘}’ token
ipptest.cpp:83: error: expected ‘;’ before ‘}’ token

Compilation exited abnormally with code 1 at Thu Feb 23 09:05:13

 

0 Kudos
1 Reply
Highlighted
Beginner
52 Views

Never mind! I was still pointing to the IPP 7.1 we have installed and hadn't updated IPPROOT.

Sigh.

0 Kudos