Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
4 Views

Compile the IPP Sample with Intel compiler

Dear experts
How can I compile the IPP sample code (ex. audio-video-codecs) with the Intel compiler if the compiler is not install at the default location? I try to compile it with the command build32.bat icl110. I got the error message
"ERROR: Compiler "icl110" environment is not found". which part I should modify to compile the sample code??
Thanks for your reply.
0 Kudos
3 Replies
Highlighted
Employee
4 Views



Hi,

You can check the file:
ipp-samplestoolsenvsearch_compilers.bat


In the part:

:SET_INTEL_ENV
set COMPILER=icl.exe

set ptn= dir /B /ON "%PrF%IntelCompilerC++%1.*"
@%ptn% 2>NUL 1>&2
if "%errorlevel%"=="0" for /F "usebackq" %%i in (`%ptn%`) do set LASTVERSION=%%i
set ENV="%PrF%IntelCompilerC++%LASTVERSION%%AR%Biniclvars.bat"

if exist %ENV% (
set TOOL=%ENV%
@echo +++ Intel C++ Compiler v.%LASTVERSION% for %AR% is taken
exit /b
)
echo --- Intel C++ Compiler %ARG% for %AR% environment is not found.
exit /b 1



Change:

set ENV="%PrF%IntelCompilerC++%LASTVERSION%%AR%Biniclvars.bat"

to your compile enviroment settings.

Thanks,
Chao

0 Kudos
Highlighted
Beginner
4 Views

Quoting - Chao Y (Intel)


Hi,

You can check the file:
ipp-samplestoolsenvsearch_compilers.bat


In the part:

:SET_INTEL_ENV
set COMPILER=icl.exe

set ptn= dir /B /ON "%PrF%IntelCompilerC++%1.*"
@%ptn% 2>NUL 1>&2
if "%errorlevel%"=="0" for /F "usebackq" %%i in (`%ptn%`) do set LASTVERSION=%%i
set ENV="%PrF%IntelCompilerC++%LASTVERSION%%AR%Biniclvars.bat"

if exist %ENV% (
set TOOL=%ENV%
@echo +++ Intel C++ Compiler v.%LASTVERSION% for %AR% is taken
exit /b
)
echo --- Intel C++ Compiler %ARG% for %AR% environment is not found.
exit /b 1



Change:

set ENV="%PrF%IntelCompilerC++%LASTVERSION%%AR%Biniclvars.bat"

to your compile enviroment settings.

Thanks,
Chao



Thanks Chao^^
0 Kudos
Highlighted
4 Views

There should be more elegant way.

To use custom compiler (for example if compiler is not at the default location) you need to set few environment variables:

set CUSTOM=yes
set COMP=icl110
set COMPILER=icl.exe
set __EXTERN_TOOL=%COMPILER_HOME%biniclvars.bat

and rerun build32.bat icl110


Regards,
Vladimir
0 Kudos