Intel® Integrated Performance Primitives
Community support and discussions relating to developing high-performance vision, signal, security, and storage applications.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

DV100 720p

arvinzchan
Beginner
169 Views
Hi, I am having a problem decoding DV100 720p. Every even frame is shifted up a 1/4 frame. The decoder works for 1080i. Is there some variable I am not setting correctly?

Thanks in advance,
Arvin
0 Kudos
5 Replies
Vladimir_Dudnik
Employee
169 Views

Hi Arvin,

there is comment from our expert:

That situation will happen if you call GetFrame() method without initialization of codec. Please check that the codec is initializedwith the following variables:

m_System = System720_60p;
m_nSystem720_LastDecodedChannel = 0;
m_nWidth = 1280;
m_nHeight = 720;

(They are needed for DV00_720p decoding)

Regards,
Vladimir

arvinzchan
Beginner
169 Views
Hi Vladimir,

Thanks for getting back to me. Turns out I was initializing the codec correctly. I was setting the width x height to 1280x720 so it does recognize the video as 720p.

The problem turns out to be in GetFrame() itself. I fixed the issue by not changing m_nSystem720_LastDecodedChannel = 2

if(m_System == System720_60p)
{
//if(m_nSystem720_LastDecodedChannel == 0)
// m_nSystem720_LastDecodedChannel = 2;
//else
m_nSystem720_LastDecodedChannel = 0;
}


Commenting out the above code in GetFrame() fixed the problem for me.

Regard,
Arvin
drastic
Beginner
169 Views
Hi All

I have the exact same shift with DV100 720p60 decode using the 5.3 IPP and latest ipp-samples. I made sure I was setting the codec up properly and tried commenting out the lines above, but no luck. DV25/50 and 1080i100 are all fine, just the 720p. Any other suggestions?

James
drastic
Beginner
169 Views
I guess another, more popular question might be, is anyone else seeing this problem in the 5.3 version of IPP?

Thanks, J
Vladimir_Dudnik
Employee
169 Views

Hello,

there is common recomendations from our expert:

1. method Init should be called before GetFrame

2. variable m_nSystem720_LastDecodedChannel should be set to 0 (zero) at initialization.

Regards,
Vladimir

Reply