Intel® Integrated Performance Primitives
Community support and discussions relating to developing high-performance vision, signal, security, and storage applications.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6628 Discussions

IPP sample code build failed with Xcode2.4 on Mac OS X

imapple
Beginner
199 Views

I have installed the IPP 5.3 and the Intel C++ Compiler Professional Edition 10.1 on my Mac OS X(10.4.10). Now I download the package m_ipp-sample_p_5.3.076 and build it. The audio-video-codecs was built successfully with Max OS shell. But the Xcode project built failed, such as the ippiDemo.xcodeproj in image-processing folder. The error message is "/Developer/SDKs/MacOSX10.4u.sdk/Library/Frameworks/Intel_IPP.framework/Intel bad magic number(not a Mach-O file) , Command /usr/bin/gcc-4.0 failed with exit code 1".

Additionally, the ippiDemoproject cannot find the libippcore.dylib, libipps.dylib and libippi.dylib because thatits path is "/Library/Frameworks/Intel_IPP.framework/Versions/5.1/ia32/lib/...". So I modified it to "/Library/Frameworks/Intel_IPP.framework/Versions/5.3.4.075/ia32/bin/...". But the same error message still exist.

0 Kudos
3 Replies
Vladimir_Dudnik
Employee
199 Views

Hello,

could you please specify IPP package info (you may find it in IPP doc folder, file ippsupport.txt)?

Regards,
Vladimir

imapple
Beginner
199 Views

My IPP package ID : m_ipp_p_5.3.4.075

Package Contents: Intel Integrated Performance Primitives 5.3 Update 4 Evaluation for Mac OS* X

My IPP sample code package ID: m_ipp-sample_p_5.3.076

Package Contents: Intel IPP Samples for Mac OS*

My Xcode version is 2.4.

I cannot find the support file of Intel C++ Compiler. But its image file name is "m_cc_p_10.1.017.dmg".

Whether I should link the Intel C++ Compiler to Xcode manually? If I should, how can i do it?

(I have built the audio-video-codesc. The simple_player work well. I can playback the mpeg file with it.)

g7akil
Beginner
199 Views
I have the same problem. I suspect the Intel_IPP file that was installed is corrupt, as I copied the file from IPP V5.2 and it linked (not sure if it will work however).

The file path is:

/Library/Frameworks/Intel_IPP.framework/Versions/5.3.4.075/em64t/
Reply