Community
cancel
Showing results for 
Search instead for 
Did you mean: 
esouka
Beginner
161 Views

fatal error LNK1104: cannot open file 'ippi.h'

i am linking visual studio 2008 with intel ipp, i put the path to ipp include directory into visual studio at properties -> c/c++ -> general -> additional include directories, i did the same for linker -> general -> additional library directories, i also put active(intelIPP) instead of active(debug), the problem is that it doesn't find header files,
fatal error LNK1104: cannot open file 'ippi.h'
what can i do?
thank you
0 Kudos
3 Replies
SergeyKostrov
Valued Contributor II
161 Views

Please follow the link below:

http://software.intel.com/en-us/forums/showpost.php?p=170167


>>...fatal error LNK1104: cannot open file 'ippi.h'...

It is a header file. It has to be included in a C/C++ source file with extension '.cpp'.
Naveen_G_Intel
Employee
161 Views

Hi,

With Microsoft* VS 2008 and IPP latest version should have option to select IPP in the configuration menu as below..

Project(in the solution explorer) Intel C++ Composer XE 2011 Select Build Components.

http://software.intel.com/en-us/articles/easiest-way-to-use-the-intel-integrated-performance-primiti...

Regards,

Naveen Gv

SergeyKostrov
Valued Contributor II
161 Views

User 'esouka' has a linker problem because 'ippi.h' was added to 'Linker' -> 'Input' ->'Additional Dependencies' field, that is asadditional library.

It was already explained to 'esouka'that 'ippi.h' is a header file and this is not a library.

Best regards,
Sergey
Reply