Intel® Integrated Performance Primitives
Community support and discussions relating to developing high-performance vision, signal, security, and storage applications.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

link ipp 7.0 update 5 as static got error.

free1006
Beginner
119 Views

I'm write below code to link the IPP libraries:

#pragma comment(lib, "../lib/Intelipp/ipps_t.lib")
#pragma comment(lib, "../lib/Intelipp/ippsc_t.lib")
#pragma comment(lib, "../lib/Intelipp/ippvc_t.lib")
#pragma comment(lib, "../lib/Intelipp/ippcc_t.lib")
#pragma comment(lib, "../lib/Intelipp/ippi_t.lib")
#pragma comment(lib, "../lib/Intelipp/ippcore_t.lib")
#pragma comment(lib, "../lib/Intelipp/libiomp5mt.lib")

When I compile it, got an error:

1>LINK : fatal error LNK1104: cannot open file 'ipps.lib'



I tried link to ipps.lib(#pragma comment(lib, "../lib/Intelipp/ipps.lib")) then compile succeeded, when I run my EXE, it reuqires the "ippcore-7.0.dll" file, but I expect use IPP as static library no DLL file requires, how to do ?

Thanks in advance.
0 Kudos
1 Reply
Jeffrey_M_Intel1
Employee
119 Views
Hello,

Have you seen the knowledge base article"Introduction to Linking with the Intel IPP 7.0 Library"? This might help.

http://software.intel.com/en-us/articles/introduction-to-linking-with-intel-ipp-70-library/

Depending on whether your Visual Studio environmentis integrated with IPPas described in "Compiling and Linking Intel IPP with Microsoft* Visual C++* and Intel C++ Compiler" you may not need to use the #pragmalinesto specify library namesat all.

http://software.intel.com/en-us/articles/intel-integrated-performance-primitives-intel-ipp-for-windo...

Visual Studio integration is set up during installation (of IPP or the package it was bundled with.) If your environment is integrated, you should be able to select one of the static options for "Use IPP". Without the integration, it should still work if your paths are correct and yourcompiler command line is set as described in the first KB article.

Please write back if this doesn't help you get started.

Regards,

Jeff
Reply