Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
9 Views

PROBLEMS running SDE when submitting request via pbs script on a cluster

Hi

 

I want to use the SDE (software development emulator) to count the number of FLOPs for my application for a certain processor that i use on the cluster on which i run my code.

I have downloaded the linux version of the SDE and when i run it with this command

./sde -hsw -iform 1 -omix instruc_mix.out -top_blocks 5000 -- /hpc/home/rogupta/C_version_current_gcc_fftw3/./computeC

in the directory where i have downloaded the code I get an error about a shared library not being found. This is strange because i didn't touch the 'kit' as it is called and i can see the file in the path mentioned.

-------------------------

SDE ERROR: Could not find file: /hpc/home/rogupta/C_version_current_gcc_fftw3/sde-external-7.45.0-2016-05-09-lin/intel64/sde-mix-mt.so
Is it possible you rearranged the kit files?
Please do not do that.

------------------------------

 

Could you please

suggest what i might be doing wrong and how can I make it work?

 

The script i use to submit to the cluster is pasted below. I have obscured the exact path but one can assume for the sake of completeness a proper path in the place of $some_path$

 

#!/bin/bash
#PBS -l select=1:ncpus=1:node_type=parallel
#PBS -l software=sde
#PBS -q short
#PBS -e ./err
#PBS -o ./outpt

module add gcc/5.1.0

module add openmpi/gcc/64/1.6.5

module add  fftw/3.3.3
cd /$some_path$/sde-external-7.45.0-2016-05-09-lin/

./sde -hsw -iform 1 -omix instruc_mix.out -top_blocks 5000 -- //$some_path$/C_version_current_gcc_fftw3/./computeC

 

Tags (1)
0 Kudos
1 Reply
Highlighted
Black Belt
9 Views

This forum doesn't have a moderator who could redirect your question to the companion isa extensions forum page.

0 Kudos