Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
4,490 Views

BIOS configuration not compatible with Optane memory

Jump to solution

Been wracking my brain trying to get Optane running. Any help with some overlooked settings would be nice. Thank you.

0 Kudos
1 Solution
idata
Community Manager
2,237 Views

Hi SIGINT,

Thank you for posting in the Intel® communities.

I noticed from the report attached that your system recognizes the Intel® Optane™ Memory but not as an NVMe* device. There are some settings that we can check in order to confirm everything is properly configured:

1. Let's first check the partition style of your system. In order to do so, please go to the Disk Management and right-click on Disk 0 (or the Disk that correspond to the bootable drive). Then click on Properties and go to the Volume tab. You will see there the partition style. If possible, please take a screenshot of the Disk Management so that I can take a look at it too.

2. Check if you have available 5MB at least of unallocated space in your boot drive. This can also be checked in Disk Management.

3. Check if the Intel® Optane™ Memory is connected to the correct M.2 slot. According to the report attached, your motherboard is the STRIX Z270G GAMING model. From the specifications of this model (https://www.asus.com/us/Motherboards/ROG-STRIX-Z270G-GAMING/specifications/ https://www.asus.com/us/Motherboards/ROG-STRIX-Z270G-GAMING/specifications/), it looks like there is a specific slot for Optane™. If there is, make sure the module is connected there. If there is not, make sure the module is connected to the M.2_2. If it's connected to the M.2_1 slot then it may have issues if a SATA drive is connected to the SATA_1 port, so other option would be to connect the SATA device in SATA_1 port (if there is any) in another SATA port.

4. Go to BIOS and make sure the RST driver is pre-configured. Go to the Advanced tab as shown in the picture below.

5. Still in the BIOS settings, confirm the SATA Mode Selection is set to Intel Optane Intel RST Premium With Intel Optane System Acceleration (RAID). This document from ASUS* will help you to navigate through the BIOS to find these settings: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

6. When the SATA Mode Selection is set this way, a new option named PCI Storage RAID Support should become available. Make sure this one is set to Enabled.

7. Then, please confirm the CSM setting is set to Disabled.

If all these settings are properly configured and the Intel RST application is installed in your system, then you should be able to enable the module.

On a side question, I noticed that your primary drive is APPLE SSD TS512C, right? Is that the drive you want to accelerate? I'm asking because that drive is an SSD. The Intel® Optane™ Memory is intended to accelerate HDDs and not SSDs. You can use it with your SSD (as long as it's a SATA drive), however you won't see the same performance increase as if you would accelerate an HDD.

I hope you find this information useful.

If you have any doubt with the steps above, feel free to ask.

Have a nice day.

Regards,

 

Diego V.

View solution in original post

4 Replies
idata
Community Manager
2,238 Views

Hi SIGINT,

Thank you for posting in the Intel® communities.

I noticed from the report attached that your system recognizes the Intel® Optane™ Memory but not as an NVMe* device. There are some settings that we can check in order to confirm everything is properly configured:

1. Let's first check the partition style of your system. In order to do so, please go to the Disk Management and right-click on Disk 0 (or the Disk that correspond to the bootable drive). Then click on Properties and go to the Volume tab. You will see there the partition style. If possible, please take a screenshot of the Disk Management so that I can take a look at it too.

2. Check if you have available 5MB at least of unallocated space in your boot drive. This can also be checked in Disk Management.

3. Check if the Intel® Optane™ Memory is connected to the correct M.2 slot. According to the report attached, your motherboard is the STRIX Z270G GAMING model. From the specifications of this model (https://www.asus.com/us/Motherboards/ROG-STRIX-Z270G-GAMING/specifications/ https://www.asus.com/us/Motherboards/ROG-STRIX-Z270G-GAMING/specifications/), it looks like there is a specific slot for Optane™. If there is, make sure the module is connected there. If there is not, make sure the module is connected to the M.2_2. If it's connected to the M.2_1 slot then it may have issues if a SATA drive is connected to the SATA_1 port, so other option would be to connect the SATA device in SATA_1 port (if there is any) in another SATA port.

4. Go to BIOS and make sure the RST driver is pre-configured. Go to the Advanced tab as shown in the picture below.

5. Still in the BIOS settings, confirm the SATA Mode Selection is set to Intel Optane Intel RST Premium With Intel Optane System Acceleration (RAID). This document from ASUS* will help you to navigate through the BIOS to find these settings: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

6. When the SATA Mode Selection is set this way, a new option named PCI Storage RAID Support should become available. Make sure this one is set to Enabled.

7. Then, please confirm the CSM setting is set to Disabled.

If all these settings are properly configured and the Intel RST application is installed in your system, then you should be able to enable the module.

On a side question, I noticed that your primary drive is APPLE SSD TS512C, right? Is that the drive you want to accelerate? I'm asking because that drive is an SSD. The Intel® Optane™ Memory is intended to accelerate HDDs and not SSDs. You can use it with your SSD (as long as it's a SATA drive), however you won't see the same performance increase as if you would accelerate an HDD.

I hope you find this information useful.

If you have any doubt with the steps above, feel free to ask.

Have a nice day.

Regards,

 

Diego V.

View solution in original post

idata
Community Manager
2,237 Views

Hi SIGINT,

 

 

I'd like to know if you still need help with this.

 

 

Regards,

 

Diego V.
idata
Community Manager
2,237 Views

Turns out some of the changes I made in BIOS didn't stick, so my testing has been going nowhere in particular. Tried a step by step document, and that helped out tremendously. Most of the things I missed out was my disk not being in GPT, Intel RST Premium not chosen in BIOS, and various other little things I overlooked. Happy to report that I've gotten everything to work, and has been getting some great results accelerating my 4TB mechanical disk.

idata
Community Manager
2,237 Views

That's great!

 

 

Thank you for reporting back your results.

 

 

If you have further questions, don't hesitate to open a new thread. We'll be more than glad to help you in any way we can.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
Reply