Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SFuru4
Novice
1,123 Views

Can not setup Optane memory due to inconsistency of Driver version and Application version

Jump to solution

When I run "Intel Optane Memory" application, it says IRST driver is old. Error code is 0xA008002E.

However, I can't update the driver via IDSA.

 

How can I proceed setup?

0 Kudos
1 Solution
SFuru4
Novice
199 Views

Hi Diego,

 

Finally I succeed setup optane memory after I reinstall windows on my computer.

I am not sure why it works, but before I reinstall, I struggled with satisfying the requirement of optane memory(ex: bios mode, partitioning of the disk...), so something might go wrong.

 

I attached the ssu log for your information.

# BTW, I am sure my computer works UEFI mode, but ssu says it works legacy mode... I wonder why.

 

Regards,

Shingo

 

View solution in original post

7 Replies
DiegoV_Intel
Moderator
199 Views

Hi SFuru4,

 

Thank you for posting in the Intel® communities.

 

I haven’t seen the error message you currently have, but I saw this error code in the following thread and it was fixed just by re-installing the Intel® RST application: https://forums.intel.com/s/question/0D50P0000490OkzSAE/optane-error-0xa008002e

However, when I saw the error message you shared in your screenshot, I thought that maybe the BIOS is not updated. Besides the Intel® RST driver, the BIOS must be updated to include the Intel® RST pre-OS UEFI driver, so maybe this is the drive you need to update.

 

Having said this, my recommendations are the following. Please try them in the following order:

 

  1. Uninstall the Intel® Optane™ Application, and install instead the Intel® RST application from the following site: https://downloadcenter.intel.com/download/28400/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf.... Both applications work to setup the module, but it could be that installing this application instead work for you. If you still get the error message, please take another screenshot.
  2. Check if your BIOS is up to date. This can be done by contacting the motherboard’s manufacturer to confirm if the BIOS is updated or not.
  3. If your BIOS is up to date, but the issue is still happening, please download the Intel® System Support Utility (SSU) from the following site and run the full report to get all details of your system. You can export the output in a text file so that you can share it in your response: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

I will be waiting for your response.

 

Have a nice day

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

DiegoV_Intel
Moderator
199 Views

Hi SFuru4,

 

I would like to know if you have any updates.

 

Have a nice day

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

DiegoV_Intel
Moderator
199 Views

Hi SFuru4,

 

If you have any updates, feel free to share them here.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

SFuru4
Novice
199 Views

Hi Diego,

Sorry for late reply. I mistakenly overwrite windows uefi partition, I will try your suggestion later.

I will done it on the next weekend.

Still, I have already tried re-install RST app and checked BIOS update before the mistake, so I think I will end up attaching SSU report.

 

Thank you,

Shingo​

DiegoV_Intel
Moderator
199 Views

Hi Shingo,

 

Thank you for the response.

 

I’ll be waiting for your updates.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

SFuru4
Novice
200 Views

Hi Diego,

 

Finally I succeed setup optane memory after I reinstall windows on my computer.

I am not sure why it works, but before I reinstall, I struggled with satisfying the requirement of optane memory(ex: bios mode, partitioning of the disk...), so something might go wrong.

 

I attached the ssu log for your information.

# BTW, I am sure my computer works UEFI mode, but ssu says it works legacy mode... I wonder why.

 

Regards,

Shingo

 

View solution in original post

DiegoV_Intel
Moderator
199 Views

Hi Shingo,

 

It’s great everything is up and running now. Thank you for the confirmation.

 

Regarding to the SSU report, you are correct. The system appears to be working in Legacy mode, but the fact that the Intel® Optane™ Memory is setup and enabled means that the system is indeed working in UEFI mode, otherwise you wouldn’t have been able to setup the module in first place.

 

I have seen this behavior only one time, and it was because one of the drives in the system was working with MBR partition style. The recommended partition style is GPT, and actually, the drive that is going to be accelerated must be using GPT partition style. I’m not sure if this is how the system itself behaves, but when there is one or more drives using MBR partition style, the system automatically changes to Legacy mode so these drives can be recognized properly by the OS. This automatic change happens even though you had configured the BIOS to work in UEFI mode. In other systems, the system doesn’t change and it keeps in UEFI mode but the drives using MBR partition style are not recognized in the OS.

 

I have noticed that you have several drives in your system, but I’m not sure if this is what it’s happening to you as well. Anyhow, if you were able to setup and enable the module, it means that the system was configured correctly so you should not have any issues.

 

Just for curiosity, you can check which partition style your drives are using following the steps below:

 

  1. Open the Command Prompt as Administrator.
  2. Run the command diskpart.
  3. Run the command list disk to display all drives in your system.

 

The drives using GPT partition style are marked with an *. The ones that don’t have this mark are using MBR partition style. If there is one or more drives using MBR partition style, then that might be the reason why the SSU report shows the Legacy mode instead of the UEFI mode.

 

This is the only possible reason I can think of.

 

I’m sharing this with you in case you want to check it, and if you prefer you can take a screenshot and share it here too. However, as I mentioned, it you were able to enable the module, then it means the system is working fine and everything is correctly configured.

 

I hope you find this information useful.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

Reply