Community
cancel
Showing results for 
Search instead for 
Did you mean: 
vska
Novice
1,527 Views

Error Enabling Intel® Optane™ Memory The Intel® Optane™ memory application ran into a problem. Error Code: 0xA0070015

Jump to solution

Previously it worked with the latest Intel® Rapid Storage Technology, so I believe all the BIOS settings were correct. I changed into Intel® Optane™ Memory and it would not work anymore.

The report from Intel® System Support Utility is as attached. Thanks in advance for any help.

 

0 Kudos
1 Solution
BrusC_Intel
Moderator
1,346 Views

Hello, vska.

 

Good day,

 

Thank you very much for waiting.

 

We have reviewed all the information and could not find anything pointing toward a problem with the Optane Module or software, there was something similar reported on a different motherboard, but this got fixed by installing the RST driver specific for that motherboard from the manufacturer's website.

 

I found the RST driver for your system on the downloads page, it is listed under the "Other" section for some reason, not under SATA as it usually is:

- https://www.asus.com/Commercial-Desktop/ASUSPRO-D640MB/HelpDesk_Download/

- Download version 17.7.0.1006

 

Based on that, our recommendations are:

 

1. Check if that OEM driver version allows you to enable Optane acceleration, you may also try other previous versions from that page.

 

[Edited as the other recommendations were not necessary and could cause other problems as confirmed by the customer]

 

I hope to hear from you soon.

 

Best regards,

 

 Bruce C.

Intel Customer Support Technician

A Contingent Worker at Intel

View solution in original post

31 Replies
LeonWaksman
Super User
1,038 Views

1.      I can suggest you to reinstall the Optane Memory software. FYI, the Intel Optane Memory application has reached End of Life and is replaced by Intel Optane Memory and Storage Management that can be downloaded from Microsoft store. Please see more information here.

2.      You should verify that the SATA mode in Bios setting is set to "Intel RST premium ….", rather than AHCI. In order to change the SATA mode without corrupting Windows, you should enter BIOS after setting Windows boot mode to SAFE. After rebooting to Windows after changing the SATA mode, you may disable the SAFE mode and boot in Normal mode.

3.      You should prepare minimum 5MB of unallocated space in the end of the drive being accelerated.

4.      Open Apps & Features (Windows Settings) and uninstall the currently installed Optane Application, Optane Memory Extension  and Intel RST Driver (if any)

5.      Download Intel RST Driver and unzip it on your drive. Right click on iaStorAC.inf and select install from drop down menu. Reboot your computer.

6.      Download from Microsoft Store and install the Intel Optane Memory and Management.

7.      Now enable Optane Acceleration. Follow Intel Optane Memory Installation Guide, Section 3.

 

Leon

 

 

vska
Novice
1,038 Views

Dear Leon,

 

Thank you for your reply. I have followed your instructions exactly but the problem still persists.

  1. Uninstalled the Intel® Optane™ Memory.
  2. Verified the BIOS as attached.
  3. The drive in question INTEL SSDSC2BW120A4 is empty with unallocated 111.79 GB space.
  4. Uninstalled everything.
  5. Downloaded and installed the driver. Afterward rebooted the PC.
  6. Downloaded the app.
  7. Problem still persists.Error Code.jpeg
LeonWaksman
Super User
1,038 Views
  1. Did you disabled Optane acceleration before uninstalling Optane Application? You can use diskpart command clean all on the 32GB Optane module to wipe it from old content.
  2. Update your BIOS to Version 323 2020/04/09
  3. You should ask in Asus support if there are any restriction.
  4. BTW, you don't need to leave 120GB unallocated space on your SATA SSD. 5 MB - 15MB in the drive end is enough.

 

Leon

 

vska
Novice
1,038 Views

Dear Leon,

 

Thank you for your reply. I have again followed your instructions exactly to no avail.

  1. I have disabled the Optane acceleration in the first time before I removed the Intel® Rapid Storage Technology. I then used diskpart as suggested and wiped out the module. It is now Not Initialized as shown below:Disks.png
  2. Thank you for pointing out that my BIOS version was an old one. I have updated the BIOS version to the most recent one.
  3. I asked Asus support and there are no restriction whatsoever. As I mentioned first, the acceleration worked fine, up until I removed the Intel® Rapid Storage Technology.
  4. I have made partition on the SATA SSD accordingly as shown in the figure above.
  5. I again followed your previous instructions, uninstalled and reinstalled everything. Unfortunately, I ended up with the same outcome. I have no idea what went wrong.Error Code.jpeg
LeonWaksman
Super User
1,038 Views

Hi @vska​ 

  1. The partition look correct. Except I'm not sure that this is GPT type partition (which is required), rather than MBR. Please refer also to the para. 1.2.3, page 7 in the Intel Optane Memory Installation Guide.
  2. There are different methods how to check partition type.
  3. To may regret, I haven't other ideas right now.

 

Leon

 

vska
Novice
1,038 Views

Dear Leon,

 

Thank you for your reply. I wonder if the new Windows 10 update (Windows 10 version 2004) affects the Optane Application? As for drive partition:

  1. I double checked for the GPT type partition as follows:GPT.png
  2. Thank you for the link.
  3. Please let me know if there is anything new which I could try to fix this problem, thank you.
LeonWaksman
Super User
1,038 Views

Sorry, no other idea. I can tell you that in one of my computers (NUC7i7DNHE), I've Optane memory module installed, accelerating 1TB HDD. I'm using the the latest Intel Optane memory and Storage Management application, downloaded from Microsoft Store. I didn't have any problem to upgrade Windows to version 2004.

You may try to download Intel SSD Toolbox. Try to check your Optane drive, using the Intel tool. You may try to update the Optane module firmware .

 

 

Leon

 

vska
Novice
1,038 Views

Dear Leon,

 

Thank you for your sharing on upgrading Windows to version 2004 to prove that it is not the case. I have downloaded the most recent Intel® Solid State Drive Toolbox and check the drives along with the corresponding firmwares as follows:

Intel SSD.png

Intel Optane Firmware.pngIntel SSD Firmware.png

I can confirm that the drives have the latest firmware version. Maybe I am out of luck here on enabling the acceleration.

BrusC_Intel
Moderator
1,038 Views

Hello, vska.

 

I have been reviewing your thread and the troubleshooting steps you have tried.

 

The only recommendation I can provide right now is to check with your system manufacturer for information or detailed instructions on how to enable the acceleration for this specific motherboard. This includes the exact BIOS settings to need to enable it, as I could not find a valid reason for you to keep getting that error message.

 

You may also try to install the latest version of the Intel RST driver from your manufacturer's website, the latest specific for this motherboard (not the generic one from the Intel downloads page), to check if you have the option to enable it or possibly "clear metadata". I tried to look for documentation or Optane settings for the model listed in the SSU "ASUSPRO D640MB_S640MB", so I strongly recommend giving them a call.

 

Of course I can keep the ticket open in case you contact them and they refer you back to us.

 

I hope to hear from you soon.

 

Bruce C.

Intel Customer Support Technician

A Contingent Worker at Intel

vska
Novice
1,038 Views

Dear Bruce,

Thank you for your reply. I have mentioned that it worked with the latest Intel® Rapid Storage Technology, so I believe all the BIOS settings were correct as shown below:BIOS 1.jpg

BIOS 2.jpg

I did upgrade the BIOS version to the latest one as suggested by Leon. I called Asus Service Center and they told me that Asus does not provide Intel RST driver and they follow the generic one from Intel. I checked and followed all the instructions for the BIOS settings as follows:

http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

I also checked the motherboard compatibility with Intel® B360 chipset and it shows that it supports Intel® Optane™ Memory.

https://www.asus.com/Commercial-Desktop/ASUSPRO-D640MB/specifications/

https://www.asus.com/microsite/mb/intel-optane-ready/

I also confirmed that the drives are all recognized in the Device Manager as shown below:

Device Manager.png

Attached also please find the latest report from Intel® System Support Utility.

Tracing back to the Error Code: 0xA0070015 - An error occurred during the enabling process, but more troubleshooting is required to determine how to resolve. Please contact support under Memory and Storage for more assistance.

https://www.intel.com/content/www/us/en/support/articles/000024113/memory-and-storage/intel-optane-m...

I tried once more and the error still persists:

Error Code.jpeg

I tried back with Intel® Rapid Storage Technology, it now showed the same error:

IRST.png

I have no idea what went wrong.

BrusC_Intel
Moderator
1,038 Views

Hello, vska.

 

Thank you for the response and the information.

 

I compared your BIOS settings to the ones on a local ASUS board, I just installed the Optane module (32GB), installed the latest RST (from the ASUS website) and enabled acceleration from the RST window.

 

X299TUFMark2.png

 

Of course, these are different motherboards (even the options are slightly different) and this model has an RST driver available, and, in your case, if they instructed us to use the generic one, that is what we will have to do.

 

Do you have a spare SSD/HDD to test the Optane acceleration in a fresh Windows 10 install? Just to test if primary drive acceleration works fine, and this is easier to test if you have a spare drive (since I assume you cannot erase the 530 SSD).

 

Just to make sure, your system was booting from the 760p SSD, with the 530 SSD as secondary storage being accelerated by the Optane Memory 32GB, correct? Then you disabled the Optane acceleration and removed/uninstalled the RST application, to finally install the previous Optane Interface and here is where you encountered the error after trying to enable it, right?.

 

Let me know.

 

Best regards,

 

Bruce C.

Intel Customer Support Technician

A Contingent Worker at Intel

 

vska
Novice
1,038 Views

Dear Bruce,

 

Thank you for your reply and efforts on testing it to a local Asus board. The 530 SSD is empty without any valuable files, so we can do anything with it. Unfortunately I do not have any other spare SSD to test.

"Just to make sure, your system was booting from the 760p SSD, with the 530 SSD as secondary storage being accelerated by the Optane Memory 32GB, correct? Then you disabled the Optane acceleration and removed/uninstalled the RST application, to finally install the previous Optane Interface and here is where you encountered the error after trying to enable it, right?"

This is a perfect description on my current situation, I really appreciate your efforts on understanding the whole picture.

I will wait for your further instructions, thank you.

 

LeonWaksman
Super User
1,038 Views

Hello @vska​ 

  1. I was looking on the images from your BIOS you provided and there are some items that are not clear for me:
  2. Did you changed slot from the original installation of Optane Module from M.2_2 to M.2_1?
  3. The item M.2_2 PCIe Storage Support is set to RST Controlled. Can you check what will happen if you change it to Enabled?

 

Leon

 

vska
Novice
1,038 Views

Dear Leon,

 

Thank you for your reply.

  1. I did not physically change the slot.
  2. The only thing I did was to update the BIOS version as you suggested and the interface was changed accordingly as shown in both BIOS pictures old and new.
  3. There are only two options, RST controlled and not RST controlled, so I would assume that RST controlled means enabled.RST controlled.jpgIntel RST.jpg
LeonWaksman
Super User
1,038 Views

Hi,

  1. I'm looking at the Disk Management image you have attached few posts ago. I can see that the Optane memory is clean (Unallocated) and this is correct. But I'm seeing that it is not initialized and should be Online (see the attached image from my computer). Right-click the drive marked as "Unknown" and "Not Initialized," and select Initialize Disk.  Select GPT (GUID Partition Table) and press OK
  2. An other strange thing I can see is that on your board are two M.2 slots: M.2_1 and M.2_2. You can see on the image of previous BIOS version. Now I can see only M.2_2 slot.

 

Leon

diskManagementOptaneDisabled.jpeg

vska
Novice
1,038 Views

Dear Leon,

 

Thank you for your reply.

  1. I made sure that the drive was in GPT. GPT initialize.pngGPT optane.pngBefore Acceleration.pngI made a video to show how the drive state changes from Online to Not Initialized: https://drive.google.com/file/d/1HpWZ-jmv9w22FiphK6eTRZFbnWp3Qsru/view?usp=sharing
  2. I have no idea with the missing slot. I updated the BIOS from version 302 to 323 as you suggested without moving anything physically on the board. I would guess that the new BIOS version automatically removed the slot in question.
LeonWaksman
Super User
1,038 Views

Hi,

I really wanted to help you, but I don't know this BIOS and this board. I don't know why Enabling Optane gets the Optane drive offline. This is "blind shot", however, you may try to change the settings in M.2 slot to Not RST controlled and see if the drive will disconnect.

 

Leon

 

vska
Novice
1,038 Views

Dear Leon,

 

Thank you so much for your time and attention on my issues. I tried as you suggested to change the BIOS settings to not RST controlled and here is what I have when I open the program:

RST off.pngSo I guess the BIOS setting was correct to select RST controlled so that the drive can be recognized by the program.

BrusC_Intel
Moderator
1,038 Views

Hello, vska.

 

Good day,

 

Thank you for the response and LWAKSMAN for providing further assistance.

 

Just for testing purposes, can you install Windows 10 on the SSD 530? then install the latest RST and try to enable Optane acceleration for that drive?

 

What I pretend with this is to check it this is OS related (the OS installed on the 750p) or related to secondary drive acceleration, if this works, at least we know the Optane Memory is working fine and that your BIOS settings are correct for sure.

 

I know this may take a lot of effort and time, so let me know if this is not possible.

 

You can create a USB installer using Create Windows 10 Installation media:

 

I hope to hear from you soon.

 

Bruce C.

Intel Customer Support Technician

A Contingent Worker at Intel

BrusC_Intel
Moderator
563 Views

Hello, vska.

 

I wanted to follow up on your ticket to check if you tested what I mentioned, installing Windows 10 on that disk, and trying to enable Optane acceleration for it.

 

If you tested this or something different, or you would like additional time to work on ti, just let me know.

 

Best regards,

 

Bruce C.

Intel Customer Support Technician

A Contingent Worker at Intel

Reply