Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Dinindu
Novice
555 Views

No compatible disks for Intel Optane memory!

Jump to solution

Hi Intel,

 

I have just installed Intel Optane memory on my PC seems not working as expected.

Not sure what is the issue here, however I have attached some useful information below. I saw previous posts regarding this, but here is mine information. Please help me!

 

Thank you,

Dinindu

0 Kudos
1 Solution
LeonWaksman
Super User
145 Views

Hi Dinindu,

  1. First you need to update your Bios. You have outdated Bios version 0802. The latest Bios version is 1502 https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/TUF_H370-PRO_GAMING_WIFI/TUF-H370-PRO-GAMING-WIFI-ASUS... . FYI, in previous version, version 1402, updated RAID driver in order to support Intel Optane SSD devices was included. So, first update your driver. After the BIOS update the Optane Memory should be recognized in Bios.
  2. Although you have included lot of information, some points are not clear for me:
  3. I can see that both your drivers - the Samsung SSD and the Toshiba HDD are bootable drives. I understand that you want accelerate the HDD drive and you understand that it is not possible and not needed to accelerate the Samsung NVMe SSD. So, why the HDD havew O.S. installed?
  4. You have two M.2 slots on the board. In my opinion the Samsung SSD should be installed in M.2-2 (PCIe x 4) slot, while the Optane Memory in the M.2 -1 (PCIe x 2) slot.
  5. In addition to Bios update you should update Intel ME https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/ROG_MAXIMUS_XI_APEX/MEUpdateTool_12.0.40.1433_T.zip
  6. Once the firmware is update, check the download page to update all drivers: https://www.asus.com/us/Motherboards/TUF-H370-PRO-GAMING-WI-FI/HelpDesk_Download/

 

 

Leon

 

View solution in original post

8 Replies
LeonWaksman
Super User
146 Views

Hi Dinindu,

  1. First you need to update your Bios. You have outdated Bios version 0802. The latest Bios version is 1502 https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/TUF_H370-PRO_GAMING_WIFI/TUF-H370-PRO-GAMING-WIFI-ASUS... . FYI, in previous version, version 1402, updated RAID driver in order to support Intel Optane SSD devices was included. So, first update your driver. After the BIOS update the Optane Memory should be recognized in Bios.
  2. Although you have included lot of information, some points are not clear for me:
  3. I can see that both your drivers - the Samsung SSD and the Toshiba HDD are bootable drives. I understand that you want accelerate the HDD drive and you understand that it is not possible and not needed to accelerate the Samsung NVMe SSD. So, why the HDD havew O.S. installed?
  4. You have two M.2 slots on the board. In my opinion the Samsung SSD should be installed in M.2-2 (PCIe x 4) slot, while the Optane Memory in the M.2 -1 (PCIe x 2) slot.
  5. In addition to Bios update you should update Intel ME https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/ROG_MAXIMUS_XI_APEX/MEUpdateTool_12.0.40.1433_T.zip
  6. Once the firmware is update, check the download page to update all drivers: https://www.asus.com/us/Motherboards/TUF-H370-PRO-GAMING-WI-FI/HelpDesk_Download/

 

 

Leon

 

View solution in original post

Dinindu
Novice
145 Views

Hi @LWAKSMAN​ ,

 

Thank you so much for replying this.

 

1- Sure. I'll update my Bios.

 

2, 3 - Previously I only got HDD only (OS was installed on this). And later I installed a SSD and moved Windows from it to my new SSD using Samsung Migration software. So yes I want to accelerate HDD. I'm not sure how can I able to take HDD as NOT a Bootable drive (Without loosing my data). Its really helpful if you can give me a way to do it :)

 

4 - I have attached an image below which shows where I have installed SSD and Optane. Is it wrong?

 

5, 6 - I'll update these too 😊

 

Thanks,

Dinindu

LeonWaksman
Super User
145 Views

Hi Dinindu,

  1. First thing first. You have installed your Samsung SSD in wrong slot (i.e. M.2-1). In this slot you will get only half of speed this drive can get. You should exchange between the SSD and Optane module. Please refer to your board manual https://dlcdnets.asus.com/pub/ASUS/mb/LGA1151/TUF_H370-PRO_GAMING_WIFI/E13809_TUF_H370-PRO_GAMING_WI... . I'm not sure that after changing the position of the SSD the SSD will be still bootable and may be you will need to repeat the cloning process. If I'm not wrong the M.2 SSD in Windows 10 is sensitive to its location.
  2. You should be aware that in order to accelerate your HDD, it should have GPT type partition, rather than MBR. https://www.howtogeek.com/245610/how-to-check-if-a-disk-uses-gpt-or-mbr-and-how-to-convert-between-t... If you need to convert from MBR to GPT, you may use mbr2gpt utility. However, you need to reduce the number of partitons on your disk to maximum three https://docs.microsoft.com/en-us/windows/deployment/mbr-to-gpt .
  3. In order to protect your data, you should have your HDD backup. The easiest way to make your disk non bootable is to reformat it and then restore your data from backup. You will not be able to restore you installed programs, since there should be run now from the SSD. Only data files should be copied from the backup.

 

Leon

 

Dinindu
Novice
145 Views

Thank you,

 

1- Means its better to move SSD to M.2-2 and I can have 2x more faster than this.

2- I just checked my disk properties and I can see both are GPT type partitions.

 

So I just thinking, change positions of the SSD and Optane (First uninstall installed Optane memory). And change positions, then update bios and etc as you said. Then install Optane, hope will work.

 

Do you think changing slot will not my PC boot correctly?

LeonWaksman
Super User
145 Views
  1. Correct, the SSD in M.2-2 slot will be 2x faster since this slot has 4 x PCIe lines.
  2. Did you enabled Optane memory in slot M.2-2? If yes, first disable it before changing slot.
  3. After moving SSD to slot M.2-2, I affray (however, I'm not sure) that your PC will not boot.

 

Leon

 

Dinindu
Novice
145 Views

Hi,

 

All above configurations and updates are done (BIOS/ME updated, Slots changed) but keep getting the same error. Sad!.

I have attached the latest SSU file.

 

Thanks,

Dinindu

LeonWaksman
Super User
145 Views

Hi Dinidu,

  1. I'm sorry that my advice didn't solved your problem. I don't know what was the state of your system when you started with Optane. For example: was the SATA mode set to RAID or was it AHCI? Is this the first installation for you Optane Module or it was previously used/enabled in other system,...?
  2. I founded instruction how to set Optane memory on Asus board: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf . Read it to the end. Pay attention that there are two different methods. The first, when system SATA is set to AHCI. The second method, for system SATA mode RAID. Try to follow the relevant steps. If you don't understand something, you should address your question to Asus.
  3. If you decide to choose the AHCI method, you need first to change the SATA mode. However, you can change the SATA mode only if your Windows is set to SAFE mode first. Changining the SATA mode in Bios while the Windows is Normal mode, will result in loosing boot capability (i.e. you Windows will become unbootable).

 

Leon

Dinindu
Novice
145 Views

Hi, Thanks for your time! It was second method for me (RAID Mode).

Nothing special to see but I think all done now! :)

 

Thanks,

Dinindu

Reply