Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JSugi
Novice
5,433 Views

Why am I getting IDE Detect errors on boot.

Jump to solution

So after setting up my 32gb optane memory module on my seagate 2tb hdd secondary drive my pc will not boot after using RST and the optane memory module software to setup my memory module with my 2tb hdd. I get stuck at the press F2 to enter bios screen with an IDE detect error on my motherboard Q code screen. If I shut down the pc unplug the HDD reboot, then shut down and restart with the HDD plugged in again I can uninstall the Memory module stuff and run my pc just fine as long as the 32 gb memory module is not connected to the drive.

0 Kudos
1 Solution
JSugi
Novice
3,110 Views

Ok so I spent all day today trying to figure out what it was! I finally figured it out. When I enabled rst in the bios I noticed that remapping was enabled on both my M.2_1 and M.2_2 slots were both enabled. I disabled remapping for my M.2_1 slot which is my Samsung 970 evo boot drive, I then had to do a fresh install of WIndows on that drive. So ran I diskpart cleaned my 970 evo and did the fresh install of windows. After the fresh install I downloaded the IRST software and drivers and re enabled the Optane memory module again. I have test booted the PC multiple times since trying to replicate the IDE Detect error and everything seems to be running fine. So for future reference if you have an Asus motherboard and you are pairing the optane module with a secondary drive MAKE SURE REMAPPING IS DISABLED FOR THE DRIVE WITH YOUR OS ON IT!!!

View solution in original post

15 Replies
DiegoV_Intel
Moderator
3,110 Views
Hi JSugi, Thank you for posting in the Intel® communities. I understand that you are not able to boot after setting up the module. I’d like to check your system configuration just to see if there is something missing. Please download the Intel® System Support Utility (SSU) from the following site and run the full report to get your system details: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- Please attach the report file in your response. Additionally, please also open Disk Management and take a screenshot of the window. To open it, just press the Windows* key + x and then select the Disk Management option from the menu that will appear. Finally, please also follow these steps to take another screenshot: 1. Open the command prompt as Administrator. 2. Run the command "diskpart". 3. Run the command "list disk". Please take a screenshot of this output. I’ll be waiting for your response. Have a nice day. Regards, Diego V. Intel Customer Support Technician Under Contract to Intel Corporation
JSugi
Novice
3,110 Views

Here is the screenshot.

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

Thank you for the screenshot.

 

Could you please generate the text file using the Intel® SSU? The text file contains more details about the system. Just click “Next” to reach the step 3 and generate the text file.

 

Additionally, please also take a screenshot of the Disk Management window. To open it, just press the Windows* key + x and then select the Disk Management option from the menu that will appear.

 

I’ll be waiting for your response.

 

Have a nice day.

 

Regards,

Diego V.

 Intel Customer Support Technician

Under Contract to Intel Corporation

JSugi
Novice
3,110 Views

heres the files

JSugi
Novice
3,110 Views

SSU

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

Thank you for the information.

 

I can see that you have the Intel® Optane™ Memory with a partition (F:), the module should not have any partition so please clean any data in the module with the following steps:

 

  1. Open the Command Prompt as Administrator.
  2. Run the command diskpart.
  3. Run the command list disk to display all your drives in the system, including the Intel® Optane™ Memory. Take not of the ID number associated to the module.
  4. Run the command select disk <ID>. Use the ID for the Intel® Optane™ Memory.
  5. Run the command clean all to start the cleaning process. Make sure you selected the Intel® Optane™ Memory because this process will delete all data in the drive.

 

Once the process is complete, please try to enable the module again from the application. If you get any issue with the application, let me know and please take a screenshot if you get an error message.

 

I also recommend you to check the following ASUS* guide to configure the BIOS properly for the module: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

 

I recommend you as well to confirm if your BIOS is up to date. You can check with ASUS* directly if your BIOS is up to date: https://www.asus.com/us/Motherboards/ROG-MAXIMUS-IX-HERO/specifications/

 

This is because if your BIOS is not up to date, and it doesn’t have the Intel® RST driver version 16.x, the secondary drive acceleration won’t be possible.

 

Finally, I noticed that you didn’t reserve at least 5MB of unallocated space at the end of your primary drive. This is necessary for the module to work correctly, even though it will be paired with a secondary drive. The primary drive partitions should look like in the following picture:

 

Partitions.JPG

 

I hope you find this information useful.

 

If you have any doubts, feel free to ask.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician 

Under Contract to Intel Corporation

JSugi
Novice
3,110 Views

So after following all the directions and reinstalling optane memory and RST drivers, I shut down my pc and my motherboard came back with the same IDE Detect error.

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

Could you please take a picture of the IDE Detect error?

 

On the other hand, based on the description, I understand that you can indeed enable the module from the application, the module is paired with the drive but then you get this error when booting again, correct?

 

Could you please take a new screenshot from Disk Management just to confirm how the partitions are after following the suggestions above?

 

I’ll be waiting for your response.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

JSugi
Novice
3,110 Views

​Yes everything enables just fine. If I shut down my pc after everything is enabled I can only get to the press f2 for the bios/uefi screen. The qcode screen on the mother

board says A2 which is an IDE detect error. So prior to enabling optane memory the pc is reading all drives. After enabling the module something is stopping the mother board from reading the 2tb Seagate drive and not allowing the pc to boot. Yes both unallocated partitions are at the end of both my OS nvme drive and the 2tb Seagate drive that I was trying to pair the module with. Both of the unallocated partitions had 100mb of space which should be more than enough space for the optane module to work.

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

That’s a weird behavior.

 

I would recommend you to disconnect your other drives from the system just to confirm there is no other possible cause of the issue, including your RAID array.

 

Additionally, if possible please try to enable the module with another drive. It may be possible that your drive itself is the one that is causing the issue and not the module. I have seen some reports where the secondary drive is defective at some level and it is the root cause of the issue like in this other thread for example: https://forums.intel.com/s/question/0D50P0000491olHSAQ/unable-to-install-optane-on-z390-board

 

You may also want to try a low-level format on the secondary drive just to clean it completely and delete any corrupt data that may be affecting the setup. The following article includes some third party applications to perform a low-level format on your secondary drive: https://www.intel.com/content/www/us/en/support/articles/000006198/memory-and-storage.html

 

Additionally, since you have a RAID array in your system, it’s recommendable to use the Intel® RST application to setup the Intel® Optane™ Memory instead of the Intel® Optane™ application: https://downloadcenter.intel.com/download/28413/Intel-Rapid-Storage-Technology-Intel-RST-User-Interf...

 

I’ll be waiting for your updates.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

I’d like to know if you have updates about this.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

JSugi
Novice
3,110 Views

So I ran dskchk on the HDD and there was nothing wrong with it. I also picked up two more HDDs that were on sale and tried pairing them with 6 the memory module and I get the exact same error with the brand new hard drives. I dunno what to do with this thing anymore.

 

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

Thank you for the information.

 

If you are able to enable the module with different SATA drives, but at the end you are getting the same issue, I would say that there might be something at BIOS level that is not correctly configured.

 

The module seems to be working fine, otherwise you wouldn’t be even able to setup and enable the module from the application.

 

According to the following article, in order to support secondary drive acceleration, your system may require a BIOS update: https://www.intel.com/content/www/us/en/support/articles/000026040/memory-and-storage/intel-optane-m..., so I recommend you to contact ASUS* to confirm if there is any BIOS update available, or if there is a BIOS configuration setting that you are missing.

 

If possible, I would like to see how your partitions are currently distributed. As mentioned before, you can take a screenshot of Disk Management by pressing the Windows* key + x and then selecting the Disk Management option in order to check the partitions.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

JSugi
Novice
3,111 Views

Ok so I spent all day today trying to figure out what it was! I finally figured it out. When I enabled rst in the bios I noticed that remapping was enabled on both my M.2_1 and M.2_2 slots were both enabled. I disabled remapping for my M.2_1 slot which is my Samsung 970 evo boot drive, I then had to do a fresh install of WIndows on that drive. So ran I diskpart cleaned my 970 evo and did the fresh install of windows. After the fresh install I downloaded the IRST software and drivers and re enabled the Optane memory module again. I have test booted the PC multiple times since trying to replicate the IDE Detect error and everything seems to be running fine. So for future reference if you have an Asus motherboard and you are pairing the optane module with a secondary drive MAKE SURE REMAPPING IS DISABLED FOR THE DRIVE WITH YOUR OS ON IT!!!

View solution in original post

DiegoV_Intel
Moderator
3,110 Views

Hi JSugi,

 

That’s great!

 

Thank you for sharing your findings in the community. Other users will find this information very useful.

 

If you ever have another issue related to the Intel® Optane™ Memory, please feel free to post a new thread. We’ll try to help you in any way possible.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

Reply