Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ETren
Novice
2,520 Views

"No compatible disks for Intel Optane memory" with RAID

Jump to solution

When I open the intel optane software (not the rst software) I get the message "No compatible disks for Intel Optane memory" (whole error from C:\Users\user\Intel\Logs below). I had it running a few weeks ago with my old HDD and everything worked fine. After getting a new nvme ssd (samsung evo 960) however I cannot seem to get it working and accelerate my secondary drive (hdd raid 2; tested with one hdd and too did not work).

My setup looks like the following (all drives i tried it with, i added a 5-10MB unlocated space as said in the docs):

  • 960 evo (windows 10, 1809 - motherboard: asus prime z270a with latest bios; i7-7700k)
  • optane memory (see screenshot, sofware 16.8.0.1000)
  • raid 2 volume (this should be accelerated)
  • wdc disk (did not work with disabling this too)

BIOS has enabled all necessery things (CSM disabled, Intel Optane RST mode enabled, pci remapping enabled, uefi enabled).

The optane drive is shown in the bios but there is no "Reset to non-optane" button anymore. Now I understand that this is a rather complicated setup but even with just the wdc drive, my main ssd and the optane plugged in it will not work for me.

 

I also tried to reset optane with diskmanager - clean all etc. but with no effect. 

 

Any ideas why? Any help is appreciated! Or is there any extra step I can try, like installing drivers manually?

Tags (1)
0 Kudos
1 Solution
DiegoV_Intel
Moderator
1,280 Views

Hi ETren,

 

Thank you for the response and for the information.

 

I can see several details that you should check before trying to enable the module with the secondary drive.

 

The first thing I noticed is that your system is working in Legacy mode. This mode is not compatible with the module and will be impossible to set it up unless the system is configured to work in UEFI mode. This can be set in BIOS.

 

Additionally, I can see that your Disk 0 is not using GPT partition style and that may be causing the system to work in Legacy mode. Of course, you have to check if the BIOS is correctly configured to work in UEFI mode, however sometimes when a drive is not using GPT partition style, the system changes automatically to Legacy to successfully recognize such drive.

 

Another detail is that you cannot accelerate the RAID array nor the NVMe* drive, so the only option available would be the Disk 0 which is the one not using GPT partition style. This will make impossible the setup because the drive must use GPT partition style. Besides, this drive has also 2 partitions: D: and F:. A secondary drive that is going to be accelerated by the module must have only one partition.

 

The following article includes additional details about the secondary drive acceleration requirements: https://www.intel.com/content/www/us/en/support/articles/000027987/memory-and-storage.html

 

Finally, I also noticed that your chipset is Intel® Z270. It may be possible that your system doesn’t support secondary drive acceleration. As you can see in this article: https://www.intel.com/content/www/us/en/support/articles/000026040/memory-and-storage/intel-optane-m..., you may need to contact your motherboard manufacturer (ASUS*) to confirm your motherboard supports secondary drive acceleration or if only primary drive acceleration is possible.

 

As you can see, there are several details to check. My recommendation would be to proceed as follow:

 

1. Check first the BIOS is correctly configured. The following ASUS* guide will help you to configure the BIOS properly: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

2. Check if the system is working in UEFI mode. This can be checked in the SSU report you provided.

 

Legacy.jpg

 

3. If the BIOS is correctly configured but it still appears as Legacy, it may be related to the Disk 0 using MBR partition style. You have to format this drive (low-level format), then initialize it using GPT partition style and with only one partition.

4. Make sure again that the system is in UEFI mode.

5. Try again to enable the module using your secondary drive.

6. If you are still not able to set the module up, and you have cleaned the module’s data from the Command Prompt and formatted the Disk 0 to meet the requirements for secondary drive acceleration, the only suggestion would be to contact ASUS* to confirm your system is indeed compatible with secondary drive acceleration. If you system is not compatible, then you are only able to accelerate the system drive like I suppose was your previous setup.

 

I hope you find this information useful.

 

If there is anything else I can help you with, or if you have any doubts please don’t hesitate to ask.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

View solution in original post

5 Replies
DiegoV_Intel
Moderator
1,280 Views

Hi ETren,

 

Thank you for posting in the Intel® communities.

 

I understand that you would like to accelerate a secondary drive, actually your RAID 2 array.

 

Unfortunately, the Intel® Optane™ Memory cannot accelerate RAID arrays so what you are trying to do is not possible. However, as you mentioned, you should be able to accelerate your other HDD as long as it’s a SATA drive.

 

Having said this and considering the fact that you already cleaned the module’s data from the Command Prompt, I will ask you only for your system details and drives’ partitions.

 

Please download the Intel® System Support Utility (SSU) from the following site and run the full report. This report will include all details of your system. Please export the data in a text file and share it in your response: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

Additionally, please open Disk Management and take a screenshot of the window to check your drives’ partitions. To open Disk Management press the Windows* key + x, and then select the Disk Management option from the menu that will appear.

 

Finally, please run the following commands in the Command Prompt to take another screenshot:

 

  1. Open the Command Prompt as Administrator.
  2. Run the command diskpart.
  3. Run the command list disk. Please take a screenshot of this output.

 

On the other hand, could you please confirm if you disabled the module from the application before setting up the new NVMe* drive and before trying to accelerate the secondary drive again?

 

When the module was setup before, were you being accelerating the primary (system) drive or a secondary drive?

 

I will be waiting for your response.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

ETren
Novice
1,280 Views

Hi @DiegoV_Intel​ ,

thank you for the fast response.

 

Here are the requested files. Also I did not disable the module before but followed the steps from this post so I am able to see it in both diskpart and disk management: https://forums.intel.com/s/question/0D70P0000068dw8SAA

 

Here are both screenshots:

https://i.imgur.com/e4s8aif.jpg

https://i.imgur.com/TAZtu8p.jpg

DiegoV_Intel
Moderator
1,281 Views

Hi ETren,

 

Thank you for the response and for the information.

 

I can see several details that you should check before trying to enable the module with the secondary drive.

 

The first thing I noticed is that your system is working in Legacy mode. This mode is not compatible with the module and will be impossible to set it up unless the system is configured to work in UEFI mode. This can be set in BIOS.

 

Additionally, I can see that your Disk 0 is not using GPT partition style and that may be causing the system to work in Legacy mode. Of course, you have to check if the BIOS is correctly configured to work in UEFI mode, however sometimes when a drive is not using GPT partition style, the system changes automatically to Legacy to successfully recognize such drive.

 

Another detail is that you cannot accelerate the RAID array nor the NVMe* drive, so the only option available would be the Disk 0 which is the one not using GPT partition style. This will make impossible the setup because the drive must use GPT partition style. Besides, this drive has also 2 partitions: D: and F:. A secondary drive that is going to be accelerated by the module must have only one partition.

 

The following article includes additional details about the secondary drive acceleration requirements: https://www.intel.com/content/www/us/en/support/articles/000027987/memory-and-storage.html

 

Finally, I also noticed that your chipset is Intel® Z270. It may be possible that your system doesn’t support secondary drive acceleration. As you can see in this article: https://www.intel.com/content/www/us/en/support/articles/000026040/memory-and-storage/intel-optane-m..., you may need to contact your motherboard manufacturer (ASUS*) to confirm your motherboard supports secondary drive acceleration or if only primary drive acceleration is possible.

 

As you can see, there are several details to check. My recommendation would be to proceed as follow:

 

1. Check first the BIOS is correctly configured. The following ASUS* guide will help you to configure the BIOS properly: http://dlcdnmkt.asus.com/microsite/Optane-Memory-SOP.pdf

2. Check if the system is working in UEFI mode. This can be checked in the SSU report you provided.

 

Legacy.jpg

 

3. If the BIOS is correctly configured but it still appears as Legacy, it may be related to the Disk 0 using MBR partition style. You have to format this drive (low-level format), then initialize it using GPT partition style and with only one partition.

4. Make sure again that the system is in UEFI mode.

5. Try again to enable the module using your secondary drive.

6. If you are still not able to set the module up, and you have cleaned the module’s data from the Command Prompt and formatted the Disk 0 to meet the requirements for secondary drive acceleration, the only suggestion would be to contact ASUS* to confirm your system is indeed compatible with secondary drive acceleration. If you system is not compatible, then you are only able to accelerate the system drive like I suppose was your previous setup.

 

I hope you find this information useful.

 

If there is anything else I can help you with, or if you have any doubts please don’t hesitate to ask.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

View solution in original post

ETren
Novice
1,280 Views

Hi @DiegoV_Intel​ ,

 

I was so fixated on the RAID that I totally forgot to check whether the HDD was in GPT. Thank you for your help, low-level formatting was actually the solution.

Although it is strange that msinfo32.exe said that the BIOS-Mode was UEFI (screenshot attached) while the Intel software said it was not.

 

I wish you a nice evening.

 

Kind regards,

Eric

DiegoV_Intel
Moderator
1,280 Views

Hi Eric,

 

It's great the reason was only the partition style and not something else like an incompatibility issue with the system.

 

You are right, sometimes the Windows* tool reports the system as UEFI when it's actually Legacy, that's why we always ask for the SSU report.

 

Anyhow, I'm glad to know everything is up and running now. If you ever have another issue with the module or any concern about it, feel free to open a new thread.

 

We'll try to help you in any way we can.

 

Have a nice day.

 

Regards,

Diego V.

Intel Customer Support Technician

Under Contract to Intel Corporation

Reply