Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BCott
Novice
865 Views

Is there anywhere I can download iaStorAfsServiceApi.dll? I keep getting an error about it missing after updating Windows.

Jump to solution

The error I am getting is "Intel Optane(tm) Memory Pinning. Unable to load DLL 'iaStorAfsServiceApi.dll'. The specified module could not be found (Exception from HRESULT:0x8007007"

0 Kudos
1 Solution
LeonWaksman
Super User
389 Views

Reinstall your Intel RST Driver, which probably was corrupted after Windows update to version 1903. https://downloads.dell.com/FOLDER05652684M/1/Intel-Rapid-Storage-Technology-Driver-and-Management_58...

Leon

 

View solution in original post

6 Replies
AlHill
Super User
389 Views

Which windows? WIndows 10? What version? 1903? What processor model number? What motherboard/device? Specify make and model number.

 

Doc

 

BCott
Novice
389 Views

Windows 10, Version 1903. Intel Core i7-8565U (i7 8th generation). Dell Inspiron 7786

 

Thanks,

 

Brian

 

LeonWaksman
Super User
390 Views

Reinstall your Intel RST Driver, which probably was corrupted after Windows update to version 1903. https://downloads.dell.com/FOLDER05652684M/1/Intel-Rapid-Storage-Technology-Driver-and-Management_58...

Leon

 

View solution in original post

BCott
Novice
389 Views

After disabling Intel optane in RST and rebooting. I was then able to un-install the application and basic features of Intel RST using the executable above. Reboot. Then I was able to re-install Intel RST using the executable above. Reboot. Finally I re-enabled Intel optane (not sure it makes much of a difference) with one final reboot to finish the job. I no longer get the error when opening windows explorer.

 

Thanks Leon for the help, I appreciate it!

 

Brian

DDesc3
Beginner
389 Views

@LWAKSMAN​ Mine required the uninstall first before reinstalling the this piece in order to clear the error message. I agree with @BCott (Customer)​ only I did not disable Intel Optane I simply uninstalled and reinstalled. The error is gone now.

LeonWaksman
Super User
389 Views

@DDesc3​ ,

I don't know if you have Optane Memory module installed and if you are using it for HDD acceleration. Probably you don't. @BCott​ is using Optane Memory module to accelerate HDD. therefore before uninstalling the RST software, he had to disable Optane enablement first. Failing to do this may result in loosing system drive.

 

Leon

 

Reply