Intel® Optane™ Solid State Drives
Support for Issues Related to Solid State Drives based on Intel® Optane™ technology, Intel® MAS and Firmware Update Tool
394 Discussions

Trim not available in Intel Memory and Storage Tool

Paul84
Beginner
858 Views

Hi,

 

We are running many Intel D3-S4510 Series SATA SSD drives on 3 different Windows servers (2012 R2 Datacenter).

Unfortunately TRIM is not working using Intel Memory and Storage Tool (SSD Optimizer all greyed out).

 

We are using a hyperconverged storage solution (EMC ScaleIO), as a result we did not format the partitions - ScaleIO needs to work with RAW partitions. Because the partitions are RAW, Windows does not perform trim on the disks (at least, I think). Therefore we need the Intel tool to work correctly.

 

The servers are SuperMicro X11DDW-NT using Intel(R) C600+/C220+ series chipset SATA RAID Controller, we could not find a newer driver for this storage controller (current driver is 4.7.0.1098 / 24-11-2017).

 

I did allot of searching and all the results talk about installing the latest Intel NVME driver for the storage controller, but we are not using NVME.

How can we enable TRIM for our SATA SSD's? Which is very important to keep performance optimal...

 

Some screenshots to clarify:

 

The disks in Windows, we need TRIM for L/M/N/O/P-drives (which are in use by our hyperconverged storage solution):

Paul84_0-1628338016097.png

 

The driver in use for the Intel storage controller:

Paul84_1-1628338107776.png

 

Windows TRIM settings for disks, please note that the drives we need to TRIM are not available (therefore we think TRIM will not work for our Intel drives):

Paul84_2-1628338152309.png

 

Intel Memory and Storage Tool, SSD Optimizer greyed out:

Paul84_3-1628338244596.png

 

Any suggestions would be more then welcome :-). We would be happy to provide any additional information as well! Thanks in advance for your time.

 

 

Labels (1)
0 Kudos
4 Replies
BrusC_Intel
Moderator
822 Views

Hello, Paul84.


Thank you for posting in the Intel Community Support forums.


I received your case regarding the Trim/Optimizer of the Intel Memory and Storage tool, I will be glad to assist you.


There are certain requirements in order to use this functionality, having a partition and being in NTFS are some of them.


When there are problems with the Optimizer, we usually recommend to run it directly form the OS, but knowing that you have already tried that, it looks like the OS may have similar requirements/limitations for this.


If there is a community support forum for ScaleIO (or any type of support channel) , the only recommendation we can provide would be to check with them for a possible workaround or method to successfully accomplish this.


I will keep the thread open in case other community members would like to participate, but it will not be monitored by Intel support, and if you require assistance with anything else in the future, you can always contact us back by opening a new thread or via any of the other support contact methods (https://www.intel.com/content/www/us/en/support/contact-support.html).


Best regards,


Bruce C.

Intel Customer Support Technician


Paul84
Beginner
809 Views

Hi,

 

Thanks for getting back to me.

 

I tried formatting the Intel SSD drive with an NTFS partition already but no luck; giving the SSD an NTFS partition does not help enabling this feature. In addition, the secure erase feature does not work either (I unplugged the SSD and plugged it quickly again).

 

For secure erase however, I have a workaround using PartedMagic - which works correctly (the full SSD will be more or less trimmed).

 

Therefore, I think something else must be wrong.

Why are the native Intel Tools (made for this SSD) not working using a supported system?

 

Thanks and kind regards, Paul

BrusC_Intel
Moderator
794 Views

Hello, Paul84.

 

Thank you for your reply.

 

Now that the partition is NTFS, is it possible for you to un the trim/optimizer from the "Defragment and Optimize Drives" window? 

 

I installed the Intel MAS on a test bench and the Optimizer is working fine, the only problem I encountered was after formatting the RAW partition to NTFS, the IMAS window had to be refreshed so I could run it, please see below:

 

RAW partition: Optimizer disabled.

01.jpg

 

NTFS partition: Optimizer disabled (before refresh).

02.png

 

NTFS: Optimizer enabled after refresh.

03.png

 

Please also keep in mind this is not the only requirement/limitation, you can check pages 17 and 18 of the user manual for more information: 

https://downloadmirror.intel.com/30557/eng/gui-intel-mas-user-guide-342468-005us.pdf

 

Regarding the secure erase, that feature is blocked by the OS for SATA drives, according to the user guide (page 29), but it is great that you already have a workaround for that.

 

Our recommendation about contacting them for a possible alternative or workaround for the trim would be the best option if support is available.

 

If there is anything else, please let me know, I will follow up on August 13th before closing the thread.

 

Best regards,

 

Bruce C.

Intel Customer Support Technician

BrusC_Intel
Moderator
771 Views

Hello, Paul84.


If you need any additional information, please submit a new question as this thread will no longer be monitored.


If you require assistance with anything else in the future, you can always contact us back by opening a new thread or by using any of the other support methods (https://www.intel.com/content/www/us/en/support/contact-support.html).


Best regards,


Bruce C.

Intel Customer Support Technician


Reply