Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
15791 Discussions

Build Kernel and Rootfs Using Angstrom-Yocto distribution

gilramon
Beginner
296 Views

intel_question.jpg

https://rocketboards.org/foswiki/Documentation/GSRDCompilingLinux

 

I try to build the Yocto-Angstrom disribution for Arria 10 dev board.

somebody knows this error?

it says about "Invalid syntax"

 

 

0 Kudos
7 Replies
aikeu
Employee
276 Views

Hi gilramon,


In "Step4.Build Kernel and Rootfs Using Angstrom-Yocto distribution"

Are you running this and encounter the error?

repo init -u git://github.com/Angstrom-distribution/angstrom-manifest -b angstrom-v2019.06-warrior


I do not have problem running this. I was using Virtualbox Ubuntu18.4


Thanks.

Regards,

Aik Eu


gilramon
Beginner
262 Views

intel2.jpg

 

I'm running on a standalone Linux without virtual box.

Yes step number 4.

I still didn't find solution to that problem.

aikeu
Employee
254 Views

Hi gilramon,


I think it may not have something to do with virtualbox/standalone and I am not sure it has something to do with Ubuntu version or not as I was advised to use Ubuntu 18.4 previously when creating the build environment.

Can try with Ubuntu 18.4 instead?


Thanks.

Regards,

Aik Eu


gilramon
Beginner
248 Views

Unfortunately I can't move to 18.4 because I have different things that I need this version of Linux but I will try to take windows work station and install on in virtual box with 18.4 LTS version.

It's interesting what is the big different between the versions which make this error...

aikeu
Employee
233 Views

Hi gilramon,


Any difference when using Ubuntu 18.4 to run that particular repo init cmd on your side?

I will close this thread if no further issue.


Thanks.

Regards,

Aik Eu


gilramon
Beginner
229 Views

I still didn't have time to do it but I still wondering why it's not working on 20.04 LTS version.

If you don't have solution so it is possible to close the thread...

aikeu
Employee
220 Views

Hi gilramon,


Sorry that I also do not have much info regarding why 20.04 LTS version not working....


I will close this thread for now. Do raise another thread if there is any further question.




Thanks.


Regards,


Aik Eu


Reply