Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,591 Views

Can not load .sof file to the actual FPGA chip

Hello, 

 

 

Please be aware Im new to FPGA programming. 

 

 

I have tried the following code. 

 

 

http://www.alteraforum.com/forum/attachment.php?attachmentid=13091&stc=1  

 

 

Im using Altera DE2 board. 

 

 

Pin Assignment is successful. (Just imported the CSV file). 

The RUN/PROG switch on the board is on the Run mode. 

The device name that is EP2C35F672C6 matches the actual chip. 

Compilation is successful. 

USB Blaster is recognised. 

But still failed to load the .sof file on the actual chip. 

 

Please let me know how I can diagnose what is causing the problem. 

Where are the error files located? 

 

 

Please find the screenshot below. 

http://www.alteraforum.com/forum/attachment.php?attachmentid=13090&stc=1
0 Kudos
3 Replies
Altera_Forum
Honored Contributor I
175 Views

It is counter intuitive but if there is an error when the Quartus programmer tries to upload a .sof configuration, the actual error message will show in Quartus itself, not in the Quartus programmer window. Just be sure you launch the programmer from Quartus, and when you attempt to load the configuration in the FPGA and see that "Failed" information, go back to the Quartus main window and look at the messages. Hopefully you'll get more information about the problem that prevents the upload.

Altera_Forum
Honored Contributor I
175 Views

Thanks @yahdskjas. It is solved now. The problem was with a JTAG server. It said jtag server error code 89. I just had to create a config file (/etc/udev/rules.d/98-altera.rules), put the followin config and restart the server. 

 

I don't understand what this all means but it works now ;) 

 

# USB-Blaster 

 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6001", MODE="0666", SYMLINK+="usbblaster/%k" 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6002", MODE="0666", SYMLINK+="usbblaster/%k" 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6003", MODE="0666", SYMLINK+="usbblaster/%k" 

 

 

# USB-Blaster II 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6010", MODE="0666", SYMLINK+="usbblaster2/%k" 

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="09fb", ATTRS{idProduct}=="6810", MODE="0666", SYMLINK+="usbblaster2/%k"
Altera_Forum
Honored Contributor I
175 Views

Hello, 

From the terrasic web site you can download a resources cd for your board. 

In this resources set there is a tool included called system builder. 

This tool generates a basic project with all pin and other settings that you can open with quartus. 

You can try to generate, compile and download the small project to start your diagnosis from. 

There is also a DE115 manual from the same source, see chapter 5 for detailed information about the system builder. 

Best Regards, 

Johi.