Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15323 Discussions

Cannot instantiate Cyclone V Hard Processor System in Platform Designer 18.1

SBasa5
Beginner
332 Views

Software: Platform Designer 18.1 Build 625

Os: Centos 7.6

 

Steps to reproduce:

  1. File -> New System...
  2. From IP Catalog select Library / Processors and Peripherals / Hard Processor Systems / Arria V/Cyclone V Hard Processor System
  3. click Add...

 

Got error message and all in/out ports are missing in 'System Contents' view.

 

Error:

unsaved.hps_0: list element in quotes followed by ":" instead of space

  while executing

"llength $db"

  ("if" test expression)

  invoked from within

"if {[llength $db] != $PASSED_LIST_SIZE} {

  return 0

}"

  (procedure "::pin_mux_db::load" line 26)

  invoked from within

"::pin_mux_db::load $device"

  invoked from within

"set load_rc [::pin_mux_db::load $device]"

  (procedure "ensure_pin_muxing_data" line 20)

  invoked from within

"ensure_pin_muxing_data $device_family"

  (procedure "validate" line 4)

  invoked from within

"validate"

  (procedure "compose_logicalview" line 8)

  invoked from within

"compose_logicalview"

 

Warning:

unsaved.hps_0: This module has no ports or interfaces

 

Comment:

I have checked ip/altera/hps/util/pin_mux_db.tcl

My guess is that run_quartus_tcl_command does not handle "@" in my ${quartus_script_path} = /home/xxxyyy123@zzz.local/intelFPGA_lite...

 

Any quick workaround?

 

 

0 Kudos
2 Replies
SBasa5
Beginner
112 Views

Managed to find workaround by myself:

 

When working on linux.

It looks like Platform Designer scripts does not handle @ in the installation directory ( $QSYS_ROOTDIR)

Reinstalled somewhere else eg.: /opt/quartus

 

Comment:

Actually it is mentioned in documentation:

No special characters or symbols, such as !$%@^&*<>,

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/manual/quartus_install.pdf

EBERLAZARE_I_Intel
112 Views

Hi,

 

Also, it is a good practice to not use space instead use underscore "_"when renaming/creating projects folder names.

 

The same rule applies when you are going to use the SoC EDS Command Shell.

Reply