Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15380 Discussions

Error While running AOCL with -simulator switch

Debajyoti
Employee
337 Views

Hi
We are running simulation with OpenCL SDK . We used the -simulator option in-order to generated an .aocx file .
We want to run and debug on Linux kernel in a simulation mode .
We used Intel® Quartus® Prime Design Suite: 21.1.

We are seeing some error related to vsim installation . Error Snippet as attached .

Can You please help if something got missed with the setup ? 

 

Thanks

Deb

0 Kudos
5 Replies
Debajyoti
Employee
329 Views

Is the issue something to do with the Modelsim Installation related  ?

Do we need  any specific setup before running the AOCL with -simulator option ?

BoonBengT_Intel
Moderator
298 Views

Hi @Debajyoti,

 

Thank you for posting in Intel community forum and hope all is well.
From the error it seems that the compiler are not able to locate ModelSim.

 

Mind if I ask do you have modelsim installed on your environment?
If yes please do check if the HLS configuration path is set correct for HLS

 

For environment variable to check you can refer to some path mention here.
Please do let us know if that helps.

 

Best Wishes
BB

Debajyoti
Employee
271 Views

Thanks a lot for the reply . We are now able to checkout the vsim license connecting with AOCL after setting the correct $PATH 

But , unfortunately , we are seeing that once the vsim simulation starts , the Modelsim GUI window exists automatically . 

The modelsim GUI provides some error message , but we are not able to retrieve from some log files . 

we are stuck now and need help . 

We also , have the below queries related to running the Modelsim Project Files 

 

1. Can we run Modelsim on the generated RTL files explicitly  ? currently , we are using -simulator along with the .cl files to generate + simulate
2. We have used -v in the aocl command line to enable verbosity , but looks like vsim log files are not getting generated somehow . We also want to use vsim -l kind of inputs to generate the compile , simulate logs for further analysis
3. We don't want exit the VSIM GUI window if there is any ERROR occurred . 

 

Above debug aids will be very helpful to analyze the issues further 

Thanks a lot for the help

 

Regards

Deb

 

BoonBengT_Intel
Moderator
247 Views

Hi @Debajyoti,

 

Please do find the response below:
1) Unfortunately per my understanding, you can only perform a functional simulation in software for OpenCL kernels. For that you can refer to the Emulating and Debugging Your OpenCL Kernel steps here.
2) The -v command line is to generate the compilation progress, I dont think there is any connection with vsim logs, do let me know if I misunderstand the question.
3) Mind if I ask the error is related to ModelSim tool or from the design? Perhaps can check on the modelsim transcript log which usually located in the modelsim directory to see if any cause of the auto close can be identified.
Please do let us know if that helps to clarify.

 

Best Wishes
BB

BoonBengT_Intel
Moderator
210 Views

Hi @Debajyoti,

 

Greetings, as we do not receive any further clarification on what is provided. Hence thread will now be transitioned to community support and we will no longer monitor this thread. For new queries, please feel free to open a new thread and we will be right with you. Pleasure having you here.

 

Best Wishes
BB

Reply