Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15547 Discussions

I have code written for mod20 two counters in VHDL that I cannot get to compile so that I can produce waveforms, am I missing some code?

JHAUG1
Beginner
225 Views

I have code in VHDL .vhd files that I cannot get to compile to be able to run in waveform editor, I have attached the files below. I am trying to get a waveform where the clock toggles every 2ns for 60ns so I can track the outputs and see each individual output change high or low.

0 Kudos
5 Replies
Eliath_G_Intel
Employee
163 Views

Hi Joseph,

First of all, thank you for reaching us,

I'm Eliath Guzman and I'll be attending your case.

I've already read the issue you have, so give me just a couple of days to review the code carefully and to try to replicate the issue so I can give you a good solution.

 

Just a question, which version of Intel Quartus Prime Software are you using?

JHAUG1
Beginner
163 Views

Hi Eliath, thank you for helping me out with this issue. I am using Quartus Prime Lite edition 19.1, They are synchronous sequential counter circuits that I am trying to get the high and low waveforms for.

 

Thanks Eliath

Eliath_G_Intel
Employee
163 Views

Hi Joseph,

I have replicated the issue, I'm looking for the solution to help you as soon as possible.

 

thanks,

-Eliath

Eliath_G_Intel
Employee
163 Views

Hi Joseph,

 

Could you please share with me the error message you get when trying to compile please?

 

Thanks,

-Eliath

Eliath_G_Intel
Employee
163 Views

Hi Joseph,

 

The code is ok, you are not missing any files.

How were you trying to make the simulation? did you use the University waveform option or do you used ModelSim software for this?

 

Do you have any update about the issue you shared with us?

 

 

Regards,

-Eliath

Reply