Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SparkyTech
Beginner
445 Views

Nios 2 Eclipse Not Opening

Does anyone know how to get the "Nios 2 build tools for eclipse" under tools to work in Quartus Prime version 20.1 lite edition? I'm running this on a Windows 10 machine. Whenever I click it my mouse icon indicates that something is loading then it goes back to normal and nothing pops up.

 

I've tried running it as admin and reinstalling it, but nothing works. I've seen some posts suggest downgrading to version 18.1, but none of the download links on Intel's site seem to work. I was only able to download version 20.1 by spam clicking the download button until it decided to let me download it.

 

Any help would be greatly appreciated.

0 Kudos
6 Replies
EricMunYew_C_Intel
Moderator
422 Views

Hi, Matthew


Can you follow below to re-install again:


1. install WSL for windows

i. https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/nios2/n2sw_nii5v2gen2.pd... (chapter 2.1)

  Note: Windows 10 build version 16215.0 or higher is the recommended operating system version.

ii. After installation has successfully completed, launch Ubuntu 18.04.

iii. Install additional distro packages required for Nios II EDS using the following commands:

 a. sudo apt-get update

b. sudo apt install wsl

 c. sudo apt install dos2unix

 d. sudo apt install make

 

2. install nios2 eclipse folder

https://www.intel.com/content/altera-www/global/en_us/index/support/support-resources/knowledge-base/...


Eric


SparkyTech
Beginner
417 Views

Hi @EricMunYew_C_Intel,

 

That seemed to get it working. I have some follow up questions.

 

- If I were looking for the "Nios II Software Developer Handbook" pdf and didn't have a direct link to it how would I find it on your site? What menus do I have to traverse to find useful documents like that for FPGA/Nios Development? I'm having a lot of trouble searching Intel's site for anything related to FPGAs.

- Does Intel plan on cleaning up the Quartus prime installer in the future to make it less complicated to install everything at the same time (i.e. Quartus prime + Eclipse)?

- Could you let the web developers for Intel know that it's extremely difficult to download Quartus prime directly from Intel? Every download button I clicked seemed to be dead and wouldn't download. Version 20.1 is the only one I was able to get downloaded and I had to click the download button many times before it would do anything. I verified that my browser was not waiting for Intel's site to load during this so there's something wrong with the site's script.

Here's a link to the web location that seems to be broken. The download options are broken for every version as far as I can tell.

https://fpgasoftware.intel.com/?edition=lite

 

SparkyTech
Beginner
414 Views

Hi @EricMunYew_C_Intel,

 

I have Eclipse working, but whenever I try an example project and try to build it I get an error for Make.

 

This is the line in the makefile that the compiler flags:

$(call adjust-path,$(ELF)) : $(APP_OBJS) $(LINKER_SCRIPT) $(APP_LDDEPS)

 

I loaded the SOPC from my project and made a BSP from that. Do you know what might be causing that? Attached is the project files. I'm just following the example project for the DECA development board.

EricMunYew_C_Intel
Moderator
397 Views

Hi, Mathew


Can you try below workarounds ?


#1 

Open a NIOS2 command shell

try and make an NIOS2 application

You get the following error: nios2-elf-gcc.exe: error: CreateProcess: No such file or directory 

To resolve this you need run the following command prior to calling make, "export WSLENV=PATH/l:${WSLENV}"


#2

With the above fix you can compile all the files but the link fails: 

  nios2-elf-g++.exe: error: missing argument to '-msys-lib='

To resolve this you need to modify the application Makefile and change the following line:

  APP_LDFLAGS += -msys-lib=$(call adjust-path-mixed,$(SYS_LIB)) to APP_LDFLAGS += -msys-lib=$(SYS_LIB)

In adjust-path-mixed should not be used in this case as SYS_LIB is a name of a library not a PATH to the library


#3

The final problem is that from eclipse debugging fails with the following error:

wslpath: /mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec: No such file or directory

wslpath: /mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec: No such file or directory

Using cable "USB-BlasterII [USB-1]", device 1, instance 0x01

Pausing target processor: OK

Restarting target processor

rm: cannot remove '/mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec': No such file or directory

To resolve this problem the Application Makefile must be modified again with the following change:

BUILD_PRE_PROCESS := to BUILD_PRE_PROCESS := touch $(ELF).srec



Eric



EricMunYew_C_Intel
Moderator
395 Views

Hi, Mathew


Can you try below workarounds ?


#1 

Open a NIOS2 command shell

try and make an NIOS2 application

You get the following error: nios2-elf-gcc.exe: error: CreateProcess: No such file or directory 

To resolve this you need run the following command prior to calling make, "export WSLENV=PATH/l:${WSLENV}"


#2

With the above fix you can compile all the files but the link fails: 

  nios2-elf-g++.exe: error: missing argument to '-msys-lib='

To resolve this you need to modify the application Makefile and change the following line:

  APP_LDFLAGS += -msys-lib=$(call adjust-path-mixed,$(SYS_LIB)) to APP_LDFLAGS += -msys-lib=$(SYS_LIB)

In adjust-path-mixed should not be used in this case as SYS_LIB is a name of a library not a PATH to the library


#3

The final problem is that from eclipse debugging fails with the following error:

wslpath: /mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec: No such file or directory

wslpath: /mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec: No such file or directory

Using cable "USB-BlasterII [USB-1]", device 1, instance 0x01

Pausing target processor: OK

Restarting target processor

rm: cannot remove '/mnt/f/main_clean/Software/omni_ip/projects/wfm_ss/example/wfm/wfm_app/wfm.elf.srec': No such file or directory

To resolve this problem the Application Makefile must be modified again with the following change:

BUILD_PRE_PROCESS := to BUILD_PRE_PROCESS := touch $(ELF).srec



Eric



EricMunYew_C_Intel
Moderator
389 Views

Reply