Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SHuan29
Beginner
1,495 Views

Problem in simulating Arria10 PLL IP with Cadence NCsim

I had been simulating with ArriaV IPs successfully. Recently I start to use Arria10 device. I tried to simulate the new FPGA in the same way I run ArriaV simulation. However I got the following error:

==========================

ncelab: *E,CUVMUR (/home/shuang/solar/altera/17.0.2/quartus/eda/sim_lib/twentynm_atoms.v,4718|29): instance 'swift2_test.dut@swift2<module>.e_core@core<module>.e_resets_clks@resets_clks<module>._fpga_pll@fpga_pll<module>.iopll_0@fpga_pll_altera_iopll_170_u37skkq<module>.altera_iopll_i@altera_iopll<module>.genblk1.twentynm_pll@twentynm_iopll_ip<module>.iopll_inst@twentynm_iopll<module>.inst' of design unit 'twentynm_iopll_encrypted' is unresolved in 'twentynm_atoms.twentynm_iopll:v'.

irun: *E,ELBERR: Error during elaboration (status 1), exiting.

===========================

It looks that some library file (twentynm_iopll_encrypted.v) is missing in Quartus installation eda directory.

 

Attached is a simplified simulation project that has only the PLL and IOs. To start simulation in Linux, type "run". The quartus library directory has already been included. The quartus I used was 17.0.2, standard edition.

 

Has anyone run in the same problem? What was your resolution?

Thanks.

0 Kudos
2 Replies
Abe
Valued Contributor II
218 Views

Have you compiled the FPGA / CPLD device libraries for CAdence NC Sim? If not, you have to do that first from Quartus II via the Tools -> FPGA library compiler. Select the appropriate simulator, key in the path to the executable and then select the devices to compile. After this you can simulate your design using the chosen simulator.

218 Views

Hi,

I have looked at the log file you shared seems like you are missing the Arria10 libraries.

 

You can refer to list of library files needed from the IP autogenerated script located at <ip_name>/sim/cadence/ncsim_setup.sh

in your case is "src/megawizard/fpga_pll/sim/cadence/ncsim_setup.sh"

 

I would suggest to reference the Library files from Quartus installation directory instead of copying to local directory, or use the Library compiler to compile these libraries as suggested in previous reply by @Abe​ 

https://www.intel.com/content/www/us/en/programmable/documentation/gtt1529956823942.html#mwh14099606...

 

 

Solution to your simulation setup. Update your sim.vc file to include all the libraries needed and then try to run simulation.

 

"

-v ./quartus/eda/sim_lib/altera_primitives.v   

-v ./quartus/eda/sim_lib/220model.v      

-v ./quartus/eda/sim_lib/sgate.v        

-v ./quartus/eda/sim_lib/altera_mf.v      

-v ./quartus/eda/sim_lib/altera_lnsim.sv    

-v ./quartus/eda/sim_lib/twentynm_atoms.v   

-v ./quartus/eda/sim_lib/cadence/twentynm_atoms_ncrypt.v    

-v ./quartus/eda/sim_lib/cadence/twentynm_hssi_atoms_ncrypt.v  

-v ./quartus/eda/sim_lib/twentynm_hssi_atoms.v         

-v ./quartus/eda/sim_lib/cadence/twentynm_hip_atoms_ncrypt.v  

-v ./quartus/eda/sim_lib/twentynm_hip_atoms.v 

"

 

Hope this information will be helpful to you in order to proceed.

 

Thanks,

Arslan

Reply