Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,473 Views

Qsys doesn't program flash correctly

I am using the latest 11.1 sp2. I have a project that came from 10.1 with SOPC. It has been working in custom hardware for over 5 years. I compiled, debugged and programmed into the flash just fine using SOPC as the system generator using 11.1. It just works as it should. 

 

When I converted the project to use Qsys, it will debug and run fine under the debugger, but I can't get it to run with the EPCS flash. It took about a week to get all the many conversion issues sorted out, but I am at a loss to find why it won't boot from flash. It looks like the SOF won't even boot when I use the flash programmer. If I program just the pof into the flash using the normal programmer, the hardware at least boots just fine. 

 

What issue does QSYS make that won't let the flash programmer work?
0 Kudos
4 Replies
Highlighted
Valued Contributor III
3 Views

Did figure it out? I think, I am having the same issue... 

 

Thanks
0 Kudos
Highlighted
Valued Contributor III
3 Views

i had the same problem with you ,in sopc builder it works well,but convert to qsys,it not boot correctly

0 Kudos
Highlighted
Valued Contributor III
3 Views

You have to tell to qsys that your EPCS component is an epcs component. Don't laugh, please :-) : in qsys component editor, in "module assignments", you must add parameter "embeddedsw.memoryinfo.is_epcs" with value "1", see 13.publishing component information to embedded software (http://www.altera.com/literature/hb/nios2/n2sw_nii52018.pdf)

0 Kudos
Highlighted
Valued Contributor III
3 Views

Can you be more specific, how to add this parameter to QSYS?

0 Kudos