Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15308 Discussions

USB blaster recognized by one Quartus version but not others

Altera_Forum
Honored Contributor I
1,826 Views

I have Quartus II 8.0, 9.0 and 12.0 Web Editions installed on my Windows 7 computer. Only version 8.0 recognizes the USB blaster cable. But I need version 12 now. I tried to uninstall/install and unplug/plug many times on different USB ports, but couldn't make it work. And I tried three different USB blaster cables. Version 12 doesn't recognize any of them. Any help is appreciated. Thanks!

0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
162 Views

Quartus doesn't play well when there are multiple versions installed. The newer versions (since at 14.0 or so) tend to be slightly happier to coexist, however the really old versions (8.0, 9.0) tend to get really finicky about having more than one on the same system. 

 

What is likely happening is that either the system environment variables are pointing to the wrong version, or the JTAG server service is running the old version of the server which will probably be incompatible with the newer version. 

 

 

In the windows environment variables for the system, what are the values for the following: 

 

QUARTUS_ROOTDIR QSYS_ROOTDIR SOPC_KIT_NIOS2  

 

If they are not already, make sure they are all pointing to the 12.0 directory rather than the 8.0 or 9.0 directories. 

 

Additionally, in the windows Services console (type "Services" into the start menu), right click on and open the properties of the "Altera JTAG Server" service. Is the "Path to executable:" pointing to the 12.0 version of Quartus? 

 

If the service is not pointing to the version of Quartus you wish to use, you'll need to reinstall the service. Open command prompt as administrator, and change to the directory shown in the "path to executable:" field. Once there, run the command: 

 

jtagserver --uninstall  

 

Reboot the computer, and then open the command prompt as admin again. This time navigate to the same directory, but for the 12.0 version of the install (e.g. C:\altera\12.0\quartus\bin\). Then run the command: 

 

jtagserver --install  

 

Reboot the computer again. 

 

You should now see in the services that the "Altera JTAG Server" is now registered with a path to the 12.0 version. 

 

Open the quartus programmer and see if your USB blaster is detected. It should hopefully be.
Altera_Forum
Honored Contributor I
162 Views

Thank you for your solution. It turned out that running Quartus as administrator solves the problem.

Reply