Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,654 Views

Why a warning occurred when I made the opencl example-"board_test" for DE1-SOC

I am running some opencl project examples with de1-soc,and I have problem when I make the host program of "board_test"(the example provided by ALTERA). 

 

As shown in the picture below,a warning occurred. I am sure I have set all the essential environment variables and I didn't change any makefile or code files . The aocl 

 

version is 16.0.0.211. 

 

Does this warning matter ? How to kill it?
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
93 Views

There is something wrong with your "LD_LIBRARY_PATH". It is not pointing to all the necessary libraries needed for compilation. Find the "libacl_emulator_..." file and make sure it is included in your LD_LIBRARY_PATH environmental variable.

Altera_Forum
Honored Contributor I
93 Views

Thanks for your reply! 

 

The " libacl_emulator_kernel_rt.so " was not found in the LD_LIBRARY_PATH , so I copy the " libacl_emulator_kernel_rt.so " to the path ("$ALTERAOCLSDKROOT"/linux64/lib), yet it doesn’t  

 

work. The same warning occurred. 

 

My environemnt variables setting is : 

export QUARTUS_ROOTDIR=/home/fpgaopencl/Software/Quartus_ii_16.0/quartus 

export ALTERAOCLSDKROOT=/home/fpgaopencl/Software/Quartus_ii_16.0/hld 

export PATH=$PATH:"$QUARTUS_ROOTDIR"/bin:"$ALTERAOCLSDKROOT"/linux64/bin:"$ALTERAOCLSDKROOT"/bin:/home/fpgaopencl/Software/Quartus_ii_16.0/soc_eds/embedded/ds-5/bin 

export LD_LIBRARY_PATH="$ALTERAOCLSDKROOT"/linux64/lib 

export AOCL_BOARD_PACKAGE_ROOT="$ALTERAOCLSDKROOT"/board/terasic/de1soc 

export QUARTUS_64BIT=1 

export LM_LICENSE_FILE=/home/fpgaopencl/Software/Quartus_ii_16.0/hld/license.dat "
Altera_Forum
Honored Contributor I
93 Views

If you are cross-compiling for an ARM SoC, you should have the ARM libraries in your path. You should NOT copy the library file to your existing LD_LIBRARY_PATH, you should add the path to the library file to LD_LIBRARY_PATH; there might be other libraries in the same path that are needed for correct compilation/linking. You should also add the path to the library file in the BSP that is provided by the board manufacturer to LD_LIBRARY_PATH.

Altera_Forum
Honored Contributor I
93 Views

Sorry to reply so late to you ! Something was wrong with my linux virtual machine.I had to reconstruct my environment and I decided to choose the version 14.0. Everything goes well on the version 14.0 (quartus、AOCL、and BSP). I found Terasic have not updated the PDF for the version 16.0 . I will contact with the Terasic support to ask some question.

Reply