Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
16694 Discussions

how to change modelsim's default file browser.

BHerr6
Novice
2,170 Views

Hello, I have been trying to get modelsim to work on my linux computer, but the modelsim is laggy and the fonts won't display correctly.

 

Screenshot at 2021-06-02 23-34-30.png

I'm using a Debian based distro. I wonder if there is any way to change this file browser to something else. Or if there is a way to fix this.

0 Kudos
8 Replies
Nurina
Employee
2,138 Views

Hi,


Did you try reinstalling ModelSim; you might have gone through a bad installation.


Otherwise can you let me know the following:

  1. Does this problem only occur when File Manager is involved?
  2. Which version of ModelSim are you using?


Regards,

Nurina


0 Kudos
BHerr6
Novice
2,127 Views

Hi, This issue only occurs with the File Manager. I'm using this version of Modelsim.

Screenshot at 2021-06-04 09-55-58.png

Even tho I can't see the font on the files. If I click on one of the folder, it refreshes and show the name for that folder. It's a weird bug tbh.

Screenshot at 2021-06-04 10-09-26.png

I'm having issues only with the file manager.

 

I also tried changing the color scheme of my computer and the color scheme of Modelsim. But it didn't help.

0 Kudos
Nurina
Employee
2,106 Views

Hi,


I'll report this problem to engineering. Can you let me know which OS you are using?


Thanks,

Nurina


0 Kudos
BHerr6
Novice
2,093 Views

My OS is parrot OS, a Debian based OS.

0 Kudos
Nurina
Employee
2,071 Views

Hi,


Can you also let me know which file manager used in modelsim? Also what CPU are you using?


Regards,

Nurina


0 Kudos
BHerr6
Novice
2,048 Views

I'm sorry for the late reply. I don't know which file manager is being used on Modelsim, but it seems to be embedded into the program, I see no child process being open by Modelsim when opening the file manager. My CPU is a Intel i7 10750H 6 Cores, 12 Threads. The device that I'm using is GS66 Stealth 10SF REV:1.0 with a Debian based distro, Parrot OS. I always had issues with Modelsim even in Arch Linux.

0 Kudos
Nurina
Employee
2,030 Views

Hi,


The root cause for your problem is ModelSim Intel FPGA does not support your current OS: https://www.intel.com/content/www/us/en/programmable/support/support-resources/download/os-support.html?elq_cid=7511234_ts1624241179952&erpm_id=10446625_ts1624241179952


Unfortunately you're going to have to live with that issue. This is not something engineering can fix since you use an unsupported OS. A possible workaround would be to use a remote desktop with a supported OS.


Apologies on the inconvenience.


Regards,

Nurina


0 Kudos
Nurina
Employee
2,012 Views

Hi, 

We did not receive any response to the previous question/reply/answer that I have provided, thus I will put this case to close pending. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions.

Regards,
Nurina

PS: If you find any comment from the community or Intel Support to be helpful, feel free to give Kudos.

0 Kudos
Reply