Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15539 Discussions

modelsim text editor tab settings

Altera_Forum
Honored Contributor II
3,383 Views

Is there a way to change the tab settings in the modelsim text editor? I'd like to set them to 3 so they match my settings in all my other editors so files look the same no matter where they're opened.

0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
1,443 Views

hi, look at Edit menu...> Preferences...> click on a tab named "by something" maybe you will find tabulation parameter. 

 

OR 

 

Modify a modelsim.ini 

 

Or wait for more detailed answers ;-)
Altera_Forum
Honored Contributor II
1,443 Views

I just came across this during a search.  

 

For reference the actual answer is  

 

Go to the tools menu and select edit preferences 

 

Then select "Source windows" 

Then "Document types" 

Then the programming/HDL language you are using (it seems the setting is per-language) 

Then spacing 

 

Then set the settings to suit your taste/coding standards. If you want it to match what quartus does by default for verilog (I can't comment on VHDL since I don't use it) then you want to set the tab stop to 3 and turn off convert tabs to spaces. I also set the auto indent to 3.
IDap0
Beginner
1,443 Views

What I had to do was similar to what is described above but not quite it.

 

Go to: tools > edit preferences

Change to the 'by name' tab

Expand 'source'

Look for 'tabs'

Set the value to the amount of spaces you want your tab to represent.

Press 'OK'

 

Enjoy :)

(windows, Modelsim starter edition 10.5b)

Reply