Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,212 Views

Installing SoC EDS v. 14.1 on 64-bit Ubuntu 14.04-- it is possible!

After much trial and error, I succeeded in installing SoC EDS version 14.1 (SoCEDSSetup-14.1.0.186-linux.run) on a 64-bit machine running Ubuntu 14.04.  

 

The Altera Soc EDS has a boatload of 32-bit dependencies: 

sudo apt-get install libqt4-gui:i386 itcl3:i386 itcl3-dev:i386 libgomp1:i386 libqtwebkit4:i386 libtbb2:i386 libtcl8.5:i386 tcl8.5-dev:i386 libxmu6:i386 libxft2:i386 libusb-0.1-4:i386 libwebkitgtk-1.0 

 

Your mileage may vary, but I thought I'd share what worked for me so other people can save themselves some time and needless aggravation. I wish Altera (and Xilinx too) would face the reality that many of their customers use a modern version of Ubuntu and support it properly. 

 

Good luck. 

 

-Robin
Tags (1)
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
115 Views

could you share your guide or reference how to install this correctly?

Altera_Forum
Honored Contributor I
115 Views

MCETIN
Beginner
115 Views

Altera_Forum
Honored Contributor I
115 Views

 

--- Quote Start ---  

See here for updated detailed instructions for v15.1. 

 

http://rocketboards.org/foswiki/view/documentation/installingds5onunsupportedlinuxdistros 

--- Quote End ---  

 

 

thanks.. this is fantastic guide!
Reply