Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
348 Discussions

ddr3 example design generate error

ramsoffer_123
New Contributor I
412 Views

Hey to you all,

I'm using Cyclone V Soc development kit.

also I'm using linux operating system red hat 6.10/7.6.

when I'm trying to generate ddr3 example design I'm getting those errors:

ramsoffer_123_0-1668955451560.jpeg

The requirement for operating system according to the readme.txt of quartus 18.1(attached to this call):

ramsoffer_123_1-1668955529382.jpeg

it seems to me like an operating system problem.

can you help me to find what is the problem?

BR,

Ram.

0 Kudos
8 Replies
AdzimZM_Intel
Employee
396 Views

Hi Ram,


Can you check with below KDB if the resolution is working at your end?

LINK: https://www.intel.com/content/www/us/en/support/programmable/articles/000086438.html


Thanks.

-Adzim


ramsoffer_123
New Contributor I
370 Views

Hi Adzim,

thank you for the fast response.

 

We are using quartus --64bit  version: 18.1 on Redhat 6 & 7 operating system,

please inform exactly what are the required libraries and packages we need to install/update.

 

BR

Ram.

ramsoffer_123
New Contributor I
354 Views

Hi Adzim,

it didnt help .

the problem is still existed.

 

We are using quartus --64bit  version: 18.1 on Redhat 6 & 7 operating system,

please inform exactly what are the required libraries and packages we need to install/update.

 

BR

Ram

 

AdzimZM_Intel
Employee
344 Views

Hi Ram,


There is a documentation for Intel FPGA software installation guide.

You may download it from the link below.

LINK: https://www.intel.com/content/www/us/en/docs/programmable/683472/18-1/introduction.html


You may be found the required libraries in the "System Requirements and Prerequisites" chapter.

Please let me know if the error still occur.

Thanks.


Regards,

Adzim


ramsoffer_123
New Contributor I
328 Views

Hey Adzim,

we followed after FPGA software installation guide and installed the proper libraries but still it's not working for us.

the same errors that describes above still showing.

 

we need you to arrange a meeting in teams/zoom/webex to help us and see what are we doing wrong.

please send me time and zone that you are available in so we can arrange this meeting.

 

BR,

Ram.

AdzimZM_Intel
Employee
252 Views

Hi Ram,


I am sorry for the delay to respond to you.

I was OOO since last week.


I believe the Quartus software that you have installed is right because you are able to open the software.

What you can do is checking the authentic Quartus installer by referring to SHA1 checksum at the Quartus download page.

Link: https://www.intel.com/content/www/us/en/software-kit/664780/intel-quartus-prime-pro-edition-design-s...


Another thing that you can try is to install the Quartus on other machine.

You also can test with other OS such as Ubuntu.


Regards,

Adzim


ramsoffer_123
New Contributor I
249 Views

Hi Adzim,

 

thank you for your response.

we manage to find the problem.

 

our operation system used GCC compiler and quartus wants to use CC compiler.

we changed it and the problem solved.

 

thank you again,

BR,

Ram.

AdzimZM_Intel
Employee
240 Views

Hi Ram,


Thank you for your feedback.


I’m glad that your question has been addressed, I now transition this thread to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Reply