Community
cancel
Showing results for 
Search instead for 
Did you mean: 
rshal2
New Contributor II
816 Views

error in DS-5 running example

Hello,

 

I see several bugs in EDS DS-5:

 

a) trying to create new project:

but pressing File-> New -> C project, nothing happens !

b) Also if I press windows->preferences->ds-5->toolchain I get window of "problem occured"....

 c)

I manage to build baremetal example from the one already installed in

C:\intelFPGA\18.1\embedded\examples\software

 

But on trying to build from fpgawiki.intel.com it fails to build!

  1. download SoCFPGA-GettingStarted-AV-ARMCC.tar.gz from https://fpgawiki.intel.com/wiki/SoCEDSGettingStarted
  2. import project file into Intels EDS DS-5
  3. build fails : **** Build of configuration Debug for project SoCFPGA- GettingStarted-AV-ARMCC **** Toolchain required to build project is not registered: ARM Compiler 5 (DS-5 built-in)

 

Is it just in EDS 18.1 is a problem ? should I downgrade ?

 

 

Can anyone please help?

Thank you

 

Tags (1)
0 Kudos
5 Replies
132 Views

Hi,

 

You might need to recheck during your import stages here. Are you using the Sample Application Projects or your own?

 

If you are still facing the same error, you can also to refer to this link to create Bare Metal application projects.

 

Regards.

rshal2
New Contributor II
132 Views

Hi,

 

Thanks for reply.

After downgrading from EDS 18.1 to EDS 16.1, it all works, and I can run the example SoCFPGA-GettingStarted-CV-ARMCC.tar.gz (from SOCEDSGettingstarted fpgawiki page)

Seems like a bug in latest EDS ?

 

Thanks,

ranran

132 Views

Hi ranran,

 

I noticed you have posted few posts regarding the error, are the other errors fixed when using EDS 16.1?

 

Because the page mentioned that the prerequisite are SoC EDS 16.1b196+, so I assume the examples are tested working as of that version.

 

Please let me know if the other errors that you faced by using 18.1 are fixed by using EDS 16.1.

 

Thanks!

rshal2
New Contributor II
132 Views

Hi,

 

Yes.

The 2nd ticket actually refer to same question. (I thought I have deleted one of them. sorry)

https://forums.intel.com/s/question/0D70P000006FEt8/bug-in-intels-soc-fpga-eds-

 

And Yes. After uninstall 18.1 and install 16.1 , all issues were solved.

I did not try to uninstall 16.1 and install 18.1 again to see if there is no issue with 18.1 (after uninstall and install).

I still don't know why 18.1 have issues with the gettingstarted example from fpgawiki page.

It seems that the build-it example (in eds folder) are probably other project type (makefile or not makefile) than the type of project from the fpgawiki page (Getting-started page).

 

I actually had another problem before when I tried to run the example from start->altera->ds-5 console , I think peaple should be careful with that....

Seems that install create 2 console, which is quite confusing!!

  1. start->altera->ds-5 console -> with this build of example fails !
  2. start->Intel's FPGA 16.1-> SOC EDS Command shell <<--- ONLY THIS SHOULD BE USED

Thanks

132 Views

Hi, Can you share which Quartus software that you use? Pro, Standard or Lite Edition? One more thing, have you installed the latest Java Runtime libraries as ARM DS-5 require Java Runtime when you build your application using 18.1? Just for checking. Thanks.
Reply