Intel® SoC FPGA Embedded Development Suite
Support for SoC FPGA Software Development, SoC FPGA HPS Architecture, HPS SoC Boot and Configuration, Operating Systems
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
266 Discussions

make (e=2): The system cannot find the file specified

pbarry999
Beginner
1,317 Views

I am new to the Cyclone SoC and have been trying to get up to speed with tools. I am struggling just to compile a basic hello world. I am using the DE10nano and have gone through their "my_first_hps" tutorial and I come to the make e=2 error. I have tried this on two different PCs. I have also tried the example "Altera-SoCFPGA-Helloworld-Baremetal-GNU" and have also received the e=2 error.

At a minimum I should be able to install and run the example.

This is the out put of the make

/cygdrive/c/intelFPGA/20.1/embedded/examples/software/Altera-SoCFPGA-HelloWorld-Baremetal-GNU
$ make
arm-eabi-gcc -mfloat-abi=softfp -mtune=cortex-a9 -mcpu=cortex-a9 -g -O0 -Werror -Wall -Wstrict-prototypes -c hello.c -o hello.o
process_begin: CreateProcess(NULL, arm-eabi-gcc -mfloat-abi=softfp -mtune=cortex-a9 -mcpu=cortex-a9 -g -O0 -Werror -Wall -Wstrict-prototypes -c hello.c -o hello.o, ...) failed.
make (e=2): The system cannot find the file specified.
make: *** [hello.o] Error 2

 

I have run the SoCEDSSetup-20.1.0.711-windows.exe and I have run the soceds-cygwin-setup.bat

I have set the environment variable SOCEDS_DEST_ROOT= C:\intelFGPA\20.1\embedded

 

 

 

0 Kudos
3 Replies
AnilErinch_A_Intel
1,309 Views

Hi 

Please make sure that you are inside the SoC EDS shell while you are running the make commands. Your SoC EDS shell needs to be started before running the embedded code. 

Please find the link , below for further reference on how to run EDS under Windows 

https://rocketboards.org/foswiki/Documentation/SoCEDS?t=2020-04-17T22:46:12+00:00

Also below forum post can also help you to debug make file related issue. 

https://community.intel.com/t5/Programmable-Devices/make-lt-e-2-gt-the-system-cannot-find-the-file-s...

Thanks and Regards

Anil

pbarry999
Beginner
1,300 Views

Thank you for your reply. The link to rocketboards.org  is enlightening, especially the part about installing linaro and MinGW, neither of which is mentioned in the documentation that I found from Intel or Terasic. That is very disappointing, I spent a lot of time trying to install not knowing this. After following those instructions, I was still having the same problems with make and have run out of enthusiasm to make this work and plan to use a device and tool flow that I have been comfortable with. I will come back to this at a later date.

Another thing that has been unclear to me is the licensing of the ARM development software. I am currently using a temp license. I see references in Intel docs that a license is provided with the development board, but that seems to only apply to Intel development boards. It seems that even though I have a license for Quartus I still need to purchase an ARM license in order to use a development board from Terasic.  

 

AnilErinch_A_Intel
1,294 Views

Hi 

The Rocketboards is also a forum supported by Intel. 

You have to get a license from ARM , since DS 5 is used for the SoC EDS. 

Please see the link below for licensing related information. 

https://rocketboards.org/foswiki/Documentation/SoCEDS?t=2020-05-27T01:34:07%2000:00#Install_ARM_DS_A...

Thanks and Regards

Anil

Reply