Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Paul_E_
Beginner
97 Views

Eclipse plugin does not support eclipse 4.6

When I try to install the eclipse plugin from the version 1.6 release, I get the following error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Software Guard Extensions Plugin 1.6.100.v20160914_34922 (com.intel.sgx.feature.feature.group 1.6.100.v20160914_34922)
  Missing requirement: Software Guard Extensions Plugin 1.6.100.v20160914_34922 (com.intel.sgx.feature.feature.group 1.6.100.v20160914_34922) requires 'org.eclipse.cdt.ui [5.11.0,6.0.0)' but it could not be found

Digging into it, I found that because I am running the version of eclipse (4.6) offered on their website, I end up with version 6.1.0.201609121658 of org.eclipse.cdt.ui, which is greater than the 6.0.0 limit. The version of eclipse in the Ubuntu repositories is too old, as it has cdt.ui version 5.9.

Going into the archived versions of eclipse and installing eclipse 4.5 allows me to install the eclipse plugin.

Is there planned support for eclipse 4.6?

0 Kudos
5 Replies
AArya2
New Contributor I
97 Views

<Bump>

AArya2
New Contributor I
97 Views

For me it didn't work on Luna or Neon.

AArya2
New Contributor I
97 Views

On Mars, it hangs on "pending" when trying to load the package.

Benny_F_
Beginner
97 Views

I cannot find any eclipse version in which I can install the plugin. Mars hangs on "pending" and all newer versions lead to the initially mentioned "issing requirement: Software Guard Extensions Plugin 1.6.100.v20160914_34922 (com.intel.sgx.feature.feature.group 1.6.100.v20160914_34922) requires 'org.eclipse.cdt.ui [5.11.0,6.0.0)' but it could not be found" error.

Can anybody tell me which version you are working with?

Hoang_N_Intel
Employee
97 Views

The current SGX Eclipse Plug-in is at https://github.com/01org/linux-sgx/tree/master/Linux_SGXEclipsePlugin and as it states in the readme.txt, it is tested only with Eclipse IDE for C/C++ Developers  4.5.1.20150917-1200.

The SGX development team is evaluating its priority to upgrade. In the meantime, this is an open source sub-project. The development community is welcome to contribute.

Reply