Intel® Software Guard Extensions (Intel® SGX)
Use hardware-based isolation and memory encryption to provide more code protection in your solutions.

Failed to load QE3: 0x4001

egalijatov
Beginner
581 Views

I was trying to test the example: https://software.intel.com/content/www/us/en/develop/articles/code-sample-gateway-key-provisioning-a... since I need to use SGX for a similar thing (generate a key and sign a file).

However, when I check whether the AESM background service is loaded and running

(using $ sudo service aemsd status) 

I get the following error:

Aug 10 14:24:24 vsi-pc-65 systemd[1]: Starting Intel(R) Architectural Enclave
Aug 10 14:24:25 vsi-pc-65 systemd[1]: Started Intel(R) Architectural Enclave
Aug 10 14:24:25 vsi-pc-65 aesm_service[17116]: [init ../../../psw/ae/aesm_service/source/core/ipc/UnixCommunicationSocket.cpp:225] Failed to connect to socket /var/run/aesmd/aesm.socket
Aug 10 14:24:25 vsi-pc-65 aesm_service[17116]: [load_qe ../qe_logic.cpp:680] Error, call sgx_create_enclave QE fail [load_qe], SGXError:4001.
Aug 10 14:24:25 vsi-pc-65 aesm_service[17116]: Failed to load QE3: 0x4001
Aug 10 14:24:25 vsi-pc-65 aesm_service[17116]: The server sock is 0x564d8b001

 

I have tried reinstall SGX driver, SGX PSW, SGX SDK but there is no effect.

Any hints on how can I solve this problem? 

Thank you in advance!

0 Kudos
1 Solution
JesusG_Intel
Moderator
557 Views

Hello Egalijatov,

 

Let's ensure everything is installed correctly. Send us the output from the following commands.

 

1. Check the SGX driver:

$ ls /dev | grep sgx

 

2. Check the PSW, especially libsgx-uae-service

$ sudo apt list --installed | grep sgx

 

3. Run sudo apt-get update to ensure all your components are up-to-date.

 

4. Setup your proxy if necessary.

Edit the file /etc/aesmd.conf (refer to the comments in the file) to set the proxy for the aesmd service.
After you configure the proxy, you need to restart the service to enable the proxy.

 

5. Check aesmd

$ ps aux | grep -aesm

$ sudo systemctl stop aesmd

$ sudo systemctl start aesmd

$ cat /var/log/syslog | grep -i aesm

 

Sincerely,

Jesus G.

 

View solution in original post

3 Replies
JesusG_Intel
Moderator
558 Views

Hello Egalijatov,

 

Let's ensure everything is installed correctly. Send us the output from the following commands.

 

1. Check the SGX driver:

$ ls /dev | grep sgx

 

2. Check the PSW, especially libsgx-uae-service

$ sudo apt list --installed | grep sgx

 

3. Run sudo apt-get update to ensure all your components are up-to-date.

 

4. Setup your proxy if necessary.

Edit the file /etc/aesmd.conf (refer to the comments in the file) to set the proxy for the aesmd service.
After you configure the proxy, you need to restart the service to enable the proxy.

 

5. Check aesmd

$ ps aux | grep -aesm

$ sudo systemctl stop aesmd

$ sudo systemctl start aesmd

$ cat /var/log/syslog | grep -i aesm

 

Sincerely,

Jesus G.

 

JesusG_Intel
Moderator
526 Views

Hello Egalijatov,


Do you still need help with this issue?


Sincerely,

Jesus G.

Intel Customer Support


JesusG_Intel
Moderator
501 Views

Hello Egalijatov,


We have not heard from you in several days so we will no longer monitor this thread. We hope you were able to resolve your issue. Please start a new thread if you need further help.


Sincerely,

Jesus G.

Intel Customer Support


Reply